summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-25 21:05:15 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-25 21:05:15 +0000
commit21437f332658723ab37a7e3d47374dd2833759c7 (patch)
treed7a7ee6bdb69c011233a7228280bdefbcad0142c /dev-lisp
parentVersion bump. (Manifest recommit) (diff)
downloadgentoo-2-21437f332658723ab37a7e3d47374dd2833759c7.tar.gz
gentoo-2-21437f332658723ab37a7e3d47374dd2833759c7.tar.bz2
gentoo-2-21437f332658723ab37a7e3d47374dd2833759c7.zip
add inherit eutils
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/sbcl/sbcl-0.8.7.ebuild16
-rw-r--r--dev-lisp/sbcl/sbcl-0.8.8.ebuild16
-rw-r--r--dev-lisp/sbcl/sbcl-0.8.9.ebuild16
3 files changed, 24 insertions, 24 deletions
diff --git a/dev-lisp/sbcl/sbcl-0.8.7.ebuild b/dev-lisp/sbcl/sbcl-0.8.7.ebuild
index 05f13ebdb784..c0bb98c4e746 100644
--- a/dev-lisp/sbcl/sbcl-0.8.7.ebuild
+++ b/dev-lisp/sbcl/sbcl-0.8.7.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.7.ebuild,v 1.1 2004/01/12 09:41:24 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.7.ebuild,v 1.2 2004/04/25 21:00:23 vapier Exp $
-inherit common-lisp-common
+inherit common-lisp-common eutils
-DESCRIPTION="Steel Bank Common Lisp (SBCL) is a Open Source development system for ANSI Common Lisp. It provides an interactive environment including an integrated native compiler, interpreter, and debugger."
-HOMEPAGE="http://sbcl.sourceforge.net/"
-IUSE="threads"
BV_X86=0.8.1
BV_PPC=0.7.13
BV_SPARC=0.7.13
BV_MIPS=0.7.10
DEB_PV=1
+DESCRIPTION="Steel Bank Common Lisp (SBCL) is a Open Source development system for ANSI Common Lisp. It provides an interactive environment including an integrated native compiler, interpreter, and debugger."
+HOMEPAGE="http://sbcl.sourceforge.net/"
SRC_URI="http://ftp.debian.org/debian/pool/main/s/sbcl/sbcl_${PV}.orig.tar.gz
mirror://sourceforge/sbcl/${P}-html.tar.bz2
http://ftp.debian.org/debian/pool/main/s/sbcl/sbcl_${PV}-${DEB_PV}.diff.gz
@@ -19,13 +18,14 @@ SRC_URI="http://ftp.debian.org/debian/pool/main/s/sbcl/sbcl_${PV}.orig.tar.gz
ppc? ( mirror://sourceforge/sbcl/${PN}-${BV_PPC}-binary-linux-ppc.tar.bz2 )
sparc? ( mirror://sourceforge/sbcl/${PN}-${BV_SPARC}-sparc-linux-binary.tar.bz2 )
mips? ( mirror://sourceforge/sbcl/${PN}-${BV_MIPS}-mips-linux-binary.tar.gz )"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~mips"
-PROVIDE="virtual/commonlisp"
-DEPEND="dev-lisp/common-lisp-controller"
+IUSE="threads"
-S=${WORKDIR}/${P}
+DEPEND="dev-lisp/common-lisp-controller"
+PROVIDE="virtual/commonlisp"
src_unpack() {
if use x86; then
diff --git a/dev-lisp/sbcl/sbcl-0.8.8.ebuild b/dev-lisp/sbcl/sbcl-0.8.8.ebuild
index e4ff5e3a5ecf..1d7fd6ee0e44 100644
--- a/dev-lisp/sbcl/sbcl-0.8.8.ebuild
+++ b/dev-lisp/sbcl/sbcl-0.8.8.ebuild
@@ -1,29 +1,29 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.8.ebuild,v 1.4 2004/03/24 21:52:12 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.8.ebuild,v 1.5 2004/04/25 21:01:38 vapier Exp $
-inherit common-lisp-common
+inherit common-lisp-common eutils
-DESCRIPTION="Steel Bank Common Lisp (SBCL) is an implementation of ANSI Common Lisp."
-HOMEPAGE="http://sbcl.sourceforge.net/"
-IUSE="threads"
BV_X86=0.8.1
BV_PPC=0.7.13
BV_SPARC=0.7.13
BV_MIPS=0.7.10
+DESCRIPTION="Steel Bank Common Lisp (SBCL) is an implementation of ANSI Common Lisp."
+HOMEPAGE="http://sbcl.sourceforge.net/"
SRC_URI="mirror://sourceforge/sbcl/${P}-source.tar.bz2
mirror://sourceforge/sbcl/${P}-html.tar.bz2
x86? ( mirror://sourceforge/sbcl/${PN}-${BV_X86}-x86-linux-binary.tar.bz2 )
ppc? ( mirror://sourceforge/sbcl/${PN}-${BV_PPC}-binary-linux-ppc.tar.bz2 )
sparc? ( mirror://sourceforge/sbcl/${PN}-${BV_SPARC}-sparc-linux-binary.tar.bz2 )
mips? ( mirror://sourceforge/sbcl/${PN}-${BV_MIPS}-mips-linux-binary.tar.gz )"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="x86 ~ppc ~sparc ~mips"
-PROVIDE="virtual/commonlisp"
-DEPEND="dev-lisp/common-lisp-controller"
+IUSE="threads"
-S=${WORKDIR}/${P}
+DEPEND="dev-lisp/common-lisp-controller"
+PROVIDE="virtual/commonlisp"
src_unpack() {
if use x86; then
diff --git a/dev-lisp/sbcl/sbcl-0.8.9.ebuild b/dev-lisp/sbcl/sbcl-0.8.9.ebuild
index 2f9c38217b08..b9265f24f472 100644
--- a/dev-lisp/sbcl/sbcl-0.8.9.ebuild
+++ b/dev-lisp/sbcl/sbcl-0.8.9.ebuild
@@ -1,29 +1,29 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.9.ebuild,v 1.1 2004/03/25 21:09:35 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.9.ebuild,v 1.2 2004/04/25 21:01:56 vapier Exp $
-inherit common-lisp-common
+inherit common-lisp-common eutils
-DESCRIPTION="Steel Bank Common Lisp (SBCL) is an implementation of ANSI Common Lisp."
-HOMEPAGE="http://sbcl.sourceforge.net/"
-IUSE="threads"
BV_X86=0.8.1
BV_PPC=0.7.13
BV_SPARC=0.7.13
BV_MIPS=0.7.10
+DESCRIPTION="Steel Bank Common Lisp (SBCL) is an implementation of ANSI Common Lisp."
+HOMEPAGE="http://sbcl.sourceforge.net/"
SRC_URI="mirror://sourceforge/sbcl/${P}-source.tar.bz2
mirror://sourceforge/sbcl/${P}-html.tar.bz2
x86? ( mirror://sourceforge/sbcl/${PN}-${BV_X86}-x86-linux-binary.tar.bz2 )
ppc? ( mirror://sourceforge/sbcl/${PN}-${BV_PPC}-binary-linux-ppc.tar.bz2 )
sparc? ( mirror://sourceforge/sbcl/${PN}-${BV_SPARC}-sparc-linux-binary.tar.bz2 )
mips? ( mirror://sourceforge/sbcl/${PN}-${BV_MIPS}-mips-linux-binary.tar.gz )"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~mips"
-PROVIDE="virtual/commonlisp"
-DEPEND="dev-lisp/common-lisp-controller"
+IUSE="threads"
-S=${WORKDIR}/${P}
+DEPEND="dev-lisp/common-lisp-controller"
+PROVIDE="virtual/commonlisp"
src_unpack() {
if use x86; then