summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-12-30 21:36:00 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-12-30 21:36:00 +0000
commit4e5f13872df9bbdfe5b4eac9e9f8fe4f1b7c93fd (patch)
treefcf5aa221adb32b1b287b926d99932f04cba6e5e /dev-lisp
parentInitial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>; P... (diff)
downloadgentoo-2-4e5f13872df9bbdfe5b4eac9e9f8fe4f1b7c93fd.tar.gz
gentoo-2-4e5f13872df9bbdfe5b4eac9e9f8fe4f1b7c93fd.tar.bz2
gentoo-2-4e5f13872df9bbdfe5b4eac9e9f8fe4f1b7c93fd.zip
New upstream version; Support for apache2 USE flag and www-apache/mod_lisp2.
(Portage version: 2.1_pre2)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-tbnl/ChangeLog7
-rw-r--r--dev-lisp/cl-tbnl/Manifest14
-rw-r--r--dev-lisp/cl-tbnl/cl-tbnl-0.9.1.ebuild36
-rw-r--r--dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.9.11
4 files changed, 46 insertions, 12 deletions
diff --git a/dev-lisp/cl-tbnl/ChangeLog b/dev-lisp/cl-tbnl/ChangeLog
index 1ef03e3106b0..9cafb0171080 100644
--- a/dev-lisp/cl-tbnl/ChangeLog
+++ b/dev-lisp/cl-tbnl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/cl-tbnl
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.23 2005/12/17 05:52:19 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.24 2005/12/30 21:36:00 mkennedy Exp $
+
+*cl-tbnl-0.9.1 (30 Dec 2005)
+
+ 30 Dec 2005; Matthew Kennedy <mkennedy@gentoo.org> +cl-tbnl-0.9.1.ebuild:
+ New upstream version; Support for apache2 USE flag and www-apache/mod_lisp2.
*cl-tbnl-0.8.9 (17 Dec 2005)
diff --git a/dev-lisp/cl-tbnl/Manifest b/dev-lisp/cl-tbnl/Manifest
index 3d11057f8a6f..dd563441fa8d 100644
--- a/dev-lisp/cl-tbnl/Manifest
+++ b/dev-lisp/cl-tbnl/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 0712d2b66e71528c60b1e71a38ae2359 ChangeLog 4053
-MD5 e4051610958787d2ff87c2ebdcbe773c cl-tbnl-0.8.9.ebuild 1012
+MD5 8ef530f6d2075a25a070f07878ae7432 cl-tbnl-0.8.9.ebuild 975
+MD5 ed898d221c360225d53443dfac565753 cl-tbnl-0.9.1.ebuild 981
MD5 b7377fe929b0307f2d7b4c8cf44965f0 files/digest-cl-tbnl-0.8.9 66
+MD5 054e9aa5186f7d89b2d17137fe7bd5dd files/digest-cl-tbnl-0.9.1 66
MD5 a2199253dbe57d398c785af8f7744485 metadata.xml 804
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDo6efyiNZaEAZA+ARAmj9AJoCl7nIFUzqMcDacCKCaTw0OUC01wCgggBR
-z+k9vo7Rx8hEHFfNYVZFz5o=
-=NYNc
------END PGP SIGNATURE-----
diff --git a/dev-lisp/cl-tbnl/cl-tbnl-0.9.1.ebuild b/dev-lisp/cl-tbnl/cl-tbnl-0.9.1.ebuild
new file mode 100644
index 000000000000..3506136159e4
--- /dev/null
+++ b/dev-lisp/cl-tbnl/cl-tbnl-0.9.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/cl-tbnl-0.9.1.ebuild,v 1.1 2005/12/30 21:36:00 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="TBNL is a toolkit for building dynamic websites with Common Lisp based on mod_lisp."
+HOMEPAGE="http://www.weitz.de/tbnl/"
+SRC_URI="mirror://gentoo/tbnl_${PV}.orig.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="standalone apache2"
+
+DEPEND="dev-lisp/cl-kmrcl
+ dev-lisp/cl-md5
+ dev-lisp/cl-base64
+ dev-lisp/cl-url-rewrite
+ dev-lisp/cl-ppcre
+ dev-lisp/cl-rfc2388"
+
+RDEPEND="${DEPEND}
+ !standalone? ( apache2? ( >=www-apache/mod_lisp2-1.2 ) !apache2? ( www-apache/mod_lisp ) )"
+
+S=${WORKDIR}/tbnl-${PV}
+
+CLPACKAGE=tbnl
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ insinto $CLSOURCEROOT/$CLPACKAGE/
+ doins -r test contrib
+ dodoc CHANGELOG README
+ dohtml doc/index.html
+}
diff --git a/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.9.1 b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.9.1
new file mode 100644
index 000000000000..513f7cb50580
--- /dev/null
+++ b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.9.1
@@ -0,0 +1 @@
+MD5 1c3456a986d0f7402ce5a00bac47b1f2 tbnl_0.9.1.orig.tar.gz 93100