summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2007-07-14 19:09:06 +0000
committerSteve Arnold <nerdboy@gentoo.org>2007-07-14 19:09:06 +0000
commit7b5b0efb15092cf050951ad46c228c705ade0afb (patch)
tree21f3a6b5479ed68e61ea601c70caeec335fe6d4d /dev-lisp
parentFix building with >=flac-1.1.3 on AMD64 systems for bug 181822, thanks to Dom... (diff)
downloadgentoo-2-7b5b0efb15092cf050951ad46c228c705ade0afb.tar.gz
gentoo-2-7b5b0efb15092cf050951ad46c228c705ade0afb.tar.bz2
gentoo-2-7b5b0efb15092cf050951ad46c228c705ade0afb.zip
fixed old and annoying bug with user-contributed patch
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/gcl/ChangeLog7
-rw-r--r--dev-lisp/gcl/files/gcl-2.6.7-fix-configure.in-bfd.patch50
-rw-r--r--dev-lisp/gcl/gcl-2.6.7.ebuild5
3 files changed, 59 insertions, 3 deletions
diff --git a/dev-lisp/gcl/ChangeLog b/dev-lisp/gcl/ChangeLog
index b38e17f054b6..f31d814efe4b 100644
--- a/dev-lisp/gcl/ChangeLog
+++ b/dev-lisp/gcl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/gcl
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gcl/ChangeLog,v 1.44 2007/07/02 15:03:30 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gcl/ChangeLog,v 1.45 2007/07/14 19:09:06 nerdboy Exp $
+
+ 14 Jul 2007; Steve Arnold <nerdboy@gentoo.org>
+ +files/gcl-2.6.7-fix-configure.in-bfd.patch, gcl-2.6.7.ebuild:
+ Fixed old and annoying bug with user-contributed patch; thanks to
+ Clemens Rabe <crabe _at_ gmx.de> for the patch.
02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> gcl-2.6.7-r2.ebuild:
(QA) RESTRICT clean up.
diff --git a/dev-lisp/gcl/files/gcl-2.6.7-fix-configure.in-bfd.patch b/dev-lisp/gcl/files/gcl-2.6.7-fix-configure.in-bfd.patch
new file mode 100644
index 000000000000..a47f279f487e
--- /dev/null
+++ b/dev-lisp/gcl/files/gcl-2.6.7-fix-configure.in-bfd.patch
@@ -0,0 +1,50 @@
+diff -Naur gcl-2.6.7.orig/configure.in gcl-2.6.7/configure.in
+--- gcl-2.6.7.orig/configure.in 2005-01-15 20:17:17.000000000 +0100
++++ gcl-2.6.7/configure.in 2007-02-13 20:40:40.000000000 +0100
+@@ -788,9 +788,9 @@
+ int main() {symbol_info t; return 0;}],
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(NEED_CONST),
+- AC_MSG_RESULT(cannot use bfd) exit 1;,
+- AC_MSG_RESULT(cannot use bfd) exit 1;),
+- AC_MSG_RESULT(cannot use bfd) exit 1;)
++ AC_MSG_RESULT(cannot use bfd); exit 1;,
++ AC_MSG_RESULT(cannot use bfd); exit 1;),
++ AC_MSG_RESULT(cannot use bfd); exit 1;)
+ ,,-liberty))
+
+ AC_DEFINE(HAVE_LIBBFD)
+@@ -1252,8 +1252,14 @@
+ return fpclass(f)>=FP_NZERO || fpclass(f)<FP_NZERO ? 0 : 1;
+ }],
+ AC_DEFINE(HAVE_IEEEFP) AC_MSG_RESULT(yes),
+- HAVE_IEEEFP=0 AC_MSG_RESULT(no),HAVE_IEEEFP=0 AC_MSG_RESULT(no))
+- ,HAVE_ISNORMAL=0 AC_MSG_RESULT(no),HAVE_ISNORMAL=0 AC_MSG_RESULT(no))
++ HAVE_IEEEFP=0
++ AC_MSG_RESULT(no),
++ HAVE_IEEEFP=0
++ AC_MSG_RESULT(no)),
++ HAVE_ISNORMAL=0
++ AC_MSG_RESULT(no),
++ HAVE_ISNORMAL=0
++ AC_MSG_RESULT(no))
+
+ AC_MSG_CHECKING([for isfinite])
+ AC_TRY_RUN([#define _GNU_SOURCE
+@@ -1271,8 +1277,14 @@
+ return finite(f) || !finite(f) ? 0 : 1;
+ }],
+ AC_DEFINE(HAVE_FINITE) AC_MSG_RESULT(yes),
+- HAVE_FINITE=0 AC_MSG_RESULT(no),HAVE_FINITE=0 AC_MSG_RESULT(no))
+- ,HAVE_ISFINITE=0 AC_MSG_RESULT(no),HAVE_ISFINITE=0 AC_MSG_RESULT(no))
++ HAVE_FINITE=0
++ AC_MSG_RESULT(no),
++ HAVE_FINITE=0
++ AC_MSG_RESULT(no))
++ ,HAVE_ISFINITE=0
++ AC_MSG_RESULT(no),
++ HAVE_ISFINITE=0
++ AC_MSG_RESULT(no))
+
+
+
diff --git a/dev-lisp/gcl/gcl-2.6.7.ebuild b/dev-lisp/gcl/gcl-2.6.7.ebuild
index 50aabdaf2dd9..b022b39f9d19 100644
--- a/dev-lisp/gcl/gcl-2.6.7.ebuild
+++ b/dev-lisp/gcl/gcl-2.6.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gcl/gcl-2.6.7.ebuild,v 1.8 2006/11/29 15:42:17 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gcl/gcl-2.6.7.ebuild,v 1.9 2007/07/14 19:09:06 nerdboy Exp $
inherit elisp-common flag-o-matic autotools
@@ -29,6 +29,7 @@ src_unpack() {
sed -e "s/gcl-doc/${PF}/g" ${S}/info/makefile > ${T}/makefile
mv ${T}/makefile ${S}/info/makefile
epatch ${FILESDIR}/${PV}-fix-configure.in-gentoo.patch || die
+ epatch ${FILESDIR}/${P}-fix-configure.in-bfd.patch || die
}
src_compile() {