summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-12-11 19:57:35 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-12-11 19:57:35 +0000
commit8880f7373198674e3fe68239569ae8a532fa57ab (patch)
treec800f761b63fc21de8fcc59d38945db9717d931c /dev-lisp
parentNew upstream version. (diff)
downloadgentoo-2-8880f7373198674e3fe68239569ae8a532fa57ab.tar.gz
gentoo-2-8880f7373198674e3fe68239569ae8a532fa57ab.tar.bz2
gentoo-2-8880f7373198674e3fe68239569ae8a532fa57ab.zip
Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>.
(Portage version: 2.0.53)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-trivial-gray-streams/ChangeLog10
-rw-r--r--dev-lisp/cl-trivial-gray-streams/Manifest3
-rw-r--r--dev-lisp/cl-trivial-gray-streams/cl-trivial-gray-streams-20051204.ebuild33
-rw-r--r--dev-lisp/cl-trivial-gray-streams/files/digest-cl-trivial-gray-streams-200512041
-rw-r--r--dev-lisp/cl-trivial-gray-streams/metadata.xml5
5 files changed, 52 insertions, 0 deletions
diff --git a/dev-lisp/cl-trivial-gray-streams/ChangeLog b/dev-lisp/cl-trivial-gray-streams/ChangeLog
new file mode 100644
index 000000000000..79ae4d33c8c5
--- /dev/null
+++ b/dev-lisp/cl-trivial-gray-streams/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/cl-trivial-gray-streams
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-trivial-gray-streams/ChangeLog,v 1.1 2005/12/11 19:57:35 mkennedy Exp $
+
+*cl-trivial-gray-streams-20051204 (11 Dec 2005)
+
+ 11 Dec 2005; Matthew Kennedy <mkennedy@gentoo.org> +metadata.xml,
+ +cl-trivial-gray-streams-20051204.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>.
+
diff --git a/dev-lisp/cl-trivial-gray-streams/Manifest b/dev-lisp/cl-trivial-gray-streams/Manifest
new file mode 100644
index 000000000000..349e87544477
--- /dev/null
+++ b/dev-lisp/cl-trivial-gray-streams/Manifest
@@ -0,0 +1,3 @@
+MD5 8080c2970d2c3e83b1a3ff7d48f49853 cl-trivial-gray-streams-20051204.ebuild 842
+MD5 78a2b4c5e7c61d55a8e372095ebb6c7c files/digest-cl-trivial-gray-streams-20051204 81
+MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
diff --git a/dev-lisp/cl-trivial-gray-streams/cl-trivial-gray-streams-20051204.ebuild b/dev-lisp/cl-trivial-gray-streams/cl-trivial-gray-streams-20051204.ebuild
new file mode 100644
index 000000000000..7a9b2664d8c9
--- /dev/null
+++ b/dev-lisp/cl-trivial-gray-streams/cl-trivial-gray-streams-20051204.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-trivial-gray-streams/cl-trivial-gray-streams-20051204.ebuild,v 1.1 2005/12/11 19:57:35 mkennedy Exp $
+
+inherit common-lisp
+
+MY_PV=${PV:0:4}-${PV:4:2}-${PV:6:2}
+MY_PN=${PN/cl-/}
+MY_P=${MY_PN}-${MY_PV}
+
+DESCRIPTION="A thin compatibility layer between Gray Stream Common Lisp implementations"
+HOMEPAGE="http://common-lisp.net/project/cl-plus-ssl/#trivial-gray-streams"
+SRC_URI="http://common-lisp.net/project/cl-plus-ssl/download/${MY_P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND=""
+
+CLPACKAGE=trivial-gray-streams
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ rm ${S}/Makefile
+}
+
+src_install() {
+ common-lisp-install *.{lisp,asd}
+ common-lisp-system-symlink
+ dodoc README COPYING
+}
diff --git a/dev-lisp/cl-trivial-gray-streams/files/digest-cl-trivial-gray-streams-20051204 b/dev-lisp/cl-trivial-gray-streams/files/digest-cl-trivial-gray-streams-20051204
new file mode 100644
index 000000000000..762c168b676a
--- /dev/null
+++ b/dev-lisp/cl-trivial-gray-streams/files/digest-cl-trivial-gray-streams-20051204
@@ -0,0 +1 @@
+MD5 c67c260a1f5e939a64435db8f862c82b trivial-gray-streams-2005-12-04.tar.gz 2633
diff --git a/dev-lisp/cl-trivial-gray-streams/metadata.xml b/dev-lisp/cl-trivial-gray-streams/metadata.xml
new file mode 100644
index 000000000000..f418045b09c8
--- /dev/null
+++ b/dev-lisp/cl-trivial-gray-streams/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+</pkgmetadata>