summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-10-02 21:30:39 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-10-02 21:30:39 +0000
commitcc9728523b1d83cfa73ce175ade2bd528036902f (patch)
treed8583b796e573dc2b80b28a3e3faef19f319cb36 /dev-lisp
parentInitial commit (diff)
downloadgentoo-2-cc9728523b1d83cfa73ce175ade2bd528036902f.tar.gz
gentoo-2-cc9728523b1d83cfa73ce175ade2bd528036902f.tar.bz2
gentoo-2-cc9728523b1d83cfa73ce175ade2bd528036902f.zip
Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>.
(Portage version: 2.0.52-r1)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-bind/ChangeLog10
-rw-r--r--dev-lisp/cl-bind/Manifest4
-rw-r--r--dev-lisp/cl-bind/cl-bind-0.1.0.ebuild30
-rw-r--r--dev-lisp/cl-bind/files/digest-cl-bind-0.1.01
-rw-r--r--dev-lisp/cl-bind/metadata.xml5
5 files changed, 50 insertions, 0 deletions
diff --git a/dev-lisp/cl-bind/ChangeLog b/dev-lisp/cl-bind/ChangeLog
new file mode 100644
index 000000000000..2952246b8c82
--- /dev/null
+++ b/dev-lisp/cl-bind/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/cl-bind
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-bind/ChangeLog,v 1.1 2005/10/02 21:30:39 mkennedy Exp $
+
+*cl-bind-0.1.0 (02 Oct 2005)
+
+ 02 Oct 2005; Matthew Kennedy <mkennedy@gentoo.org> +metadata.xml,
+ +cl-bind-0.1.0.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>.
+
diff --git a/dev-lisp/cl-bind/Manifest b/dev-lisp/cl-bind/Manifest
new file mode 100644
index 000000000000..4e88565d079b
--- /dev/null
+++ b/dev-lisp/cl-bind/Manifest
@@ -0,0 +1,4 @@
+MD5 9a27b4f8de8cdb8f38bbd76416986e93 cl-bind-0.1.0.ebuild 773
+MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
+MD5 1f39a4e19a2395096042190af7745539 ChangeLog 319
+MD5 f9f290bef085ce036706e2836f29cc33 files/digest-cl-bind-0.1.0 60
diff --git a/dev-lisp/cl-bind/cl-bind-0.1.0.ebuild b/dev-lisp/cl-bind/cl-bind-0.1.0.ebuild
new file mode 100644
index 000000000000..2cbdb6b80897
--- /dev/null
+++ b/dev-lisp/cl-bind/cl-bind-0.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-bind/cl-bind-0.1.0.ebuild,v 1.1 2005/10/02 21:30:39 mkennedy Exp $
+
+inherit common-lisp eutils
+
+DESCRIPTION="BIND combines LET*, DESTRUCTURING-BIND and MULTIPLE-VALUE-BIND into a single form."
+HOMEPAGE="http://www.cliki.net/bind http://www.metabang.com/"
+SRC_URI="http://www.metabang.com/bind_${PV}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lisp/cl-plus"
+
+S=${WORKDIR}/
+
+CLPACKAGE=with
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-gentoo.patch
+}
+
+src_install() {
+ common-lisp-install *.lisp ${FILESDIR}/with.asd
+ common-lisp-system-symlink
+ dodoc license.txt
+}
diff --git a/dev-lisp/cl-bind/files/digest-cl-bind-0.1.0 b/dev-lisp/cl-bind/files/digest-cl-bind-0.1.0
new file mode 100644
index 000000000000..2a6a7b47a7d8
--- /dev/null
+++ b/dev-lisp/cl-bind/files/digest-cl-bind-0.1.0
@@ -0,0 +1 @@
+MD5 b7ff1258e2a0a83f56b3b2a9222a206e bind_0.1.0.tar.gz 7599
diff --git a/dev-lisp/cl-bind/metadata.xml b/dev-lisp/cl-bind/metadata.xml
new file mode 100644
index 000000000000..f418045b09c8
--- /dev/null
+++ b/dev-lisp/cl-bind/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+</pkgmetadata>