summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2009-04-27 21:55:59 +0000
committerMarijn Schouten <hkbst@gentoo.org>2009-04-27 21:55:59 +0000
commitcee94aa07fc7a36dd67cb1b34985416a776b7959 (patch)
tree32059241e316c4786fef0c02c580f3639a1528e1 /dev-lisp
parentFixing python deps to include numpy. Fixes #267224. Will need boost[python] d... (diff)
downloadgentoo-2-cee94aa07fc7a36dd67cb1b34985416a776b7959.tar.gz
gentoo-2-cee94aa07fc7a36dd67cb1b34985416a776b7959.tar.bz2
gentoo-2-cee94aa07fc7a36dd67cb1b34985416a776b7959.zip
temporarily restore timestamp hack
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/sbcl/ChangeLog6
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.26-r10.ebuild13
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.27-r10.ebuild13
3 files changed, 29 insertions, 3 deletions
diff --git a/dev-lisp/sbcl/ChangeLog b/dev-lisp/sbcl/ChangeLog
index ec37f8a75fce..61d54bd9a6b2 100644
--- a/dev-lisp/sbcl/ChangeLog
+++ b/dev-lisp/sbcl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lisp/sbcl
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.156 2009/04/15 23:12:34 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.157 2009/04/27 21:55:59 hkbst Exp $
+
+ 27 Apr 2009; Marijn Schouten <hkBst@gentoo.org> sbcl-1.0.26-r10,
+ sbcl-1.0.27-r10:
+ temporarily restore timestamp hack
*sbcl-1.0.27-r10 (15 Apr 2009)
diff --git a/dev-lisp/sbcl/sbcl-1.0.26-r10.ebuild b/dev-lisp/sbcl/sbcl-1.0.26-r10.ebuild
index 615a71bf4bb5..a5ed04c78211 100644
--- a/dev-lisp/sbcl/sbcl-1.0.26-r10.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.26-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.26-r10.ebuild,v 1.1 2009/03/11 14:32:38 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.26-r10.ebuild,v 1.2 2009/04/27 21:55:59 hkbst Exp $
EAPI=2
@@ -176,4 +176,15 @@ EOF
echo "SBCL_HOME=/usr/$(get_libdir)/${PN}" > "${ENVD}"
echo "SBCL_SOURCE_ROOT=/usr/$(get_libdir)/${PN}/src" >> "${ENVD}"
doenvd "${ENVD}"
+
+ impl-save-timestamp-hack sbcl
+}
+
+pkg_postinst() {
+ standard-impl-postinst sbcl
}
+
+pkg_postrm() {
+ standard-impl-postrm sbcl /usr/bin/sbcl
+}
+
diff --git a/dev-lisp/sbcl/sbcl-1.0.27-r10.ebuild b/dev-lisp/sbcl/sbcl-1.0.27-r10.ebuild
index 03d3a0e35042..a32c90f15c6d 100644
--- a/dev-lisp/sbcl/sbcl-1.0.27-r10.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.27-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.27-r10.ebuild,v 1.1 2009/04/15 23:12:34 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.27-r10.ebuild,v 1.2 2009/04/27 21:55:59 hkbst Exp $
EAPI=2
@@ -176,4 +176,15 @@ EOF
echo "SBCL_HOME=/usr/$(get_libdir)/${PN}" > "${ENVD}"
echo "SBCL_SOURCE_ROOT=/usr/$(get_libdir)/${PN}/src" >> "${ENVD}"
doenvd "${ENVD}"
+
+ impl-save-timestamp-hack sbcl
+}
+
+pkg_postinst() {
+ standard-impl-postinst sbcl
}
+
+pkg_postrm() {
+ standard-impl-postrm sbcl /usr/bin/sbcl
+}
+