summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-10-17 17:03:16 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-10-17 17:03:16 +0000
commitf932d002c6467b5278796b58cadd20f7603771d5 (patch)
treeb357bf3ea7c4a1aa0bf2429d88777bfd7363ee32 /dev-lisp
parent*** empty log message *** (diff)
downloadgentoo-2-f932d002c6467b5278796b58cadd20f7603771d5.tar.gz
gentoo-2-f932d002c6467b5278796b58cadd20f7603771d5.tar.bz2
gentoo-2-f932d002c6467b5278796b58cadd20f7603771d5.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-statistics/ChangeLog8
-rw-r--r--dev-lisp/cl-statistics/Manifest5
-rw-r--r--dev-lisp/cl-statistics/cl-statistics-1.0.0.2.ebuild43
-rw-r--r--dev-lisp/cl-statistics/files/digest-cl-statistics-1.0.0.22
-rw-r--r--dev-lisp/cl-statistics/metadata.xml5
-rw-r--r--dev-lisp/cl-ubf/ChangeLog6
-rw-r--r--dev-lisp/cl-ubf/Manifest5
-rw-r--r--dev-lisp/cl-ubf/cl-ubf-0.2.1.ebuild10
-rw-r--r--dev-lisp/cl-ubf/metadata.xml5
9 files changed, 81 insertions, 8 deletions
diff --git a/dev-lisp/cl-statistics/ChangeLog b/dev-lisp/cl-statistics/ChangeLog
index 4d760befaab8..c79231446bd1 100644
--- a/dev-lisp/cl-statistics/ChangeLog
+++ b/dev-lisp/cl-statistics/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/cl-statistics
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-statistics/ChangeLog,v 1.1 2003/06/10 04:53:04 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-statistics/ChangeLog,v 1.2 2003/10/17 16:59:40 mkennedy Exp $
+
+*cl-statistics-1.0.0.2 (17 Oct 2003)
+
+ 17 Oct 2003; Matthew Kennedy <mkennedy@gentoo.org>
+ cl-statistics-1.0.0.2.ebuild, metadata.xml:
+ new upstream, debian, postrm, preinst
*cl-statistics-1.0.0.1 (07 Jul 2003)
diff --git a/dev-lisp/cl-statistics/Manifest b/dev-lisp/cl-statistics/Manifest
index afbc1c43002e..7a869d6da565 100644
--- a/dev-lisp/cl-statistics/Manifest
+++ b/dev-lisp/cl-statistics/Manifest
@@ -1,7 +1,6 @@
MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
-MD5 e7179b4c698de3d0d5630409d400a504 cl-statistics-1.0.0.2.ebuild~ 760
-MD5 21ac76c360b8efd34d77492a9ef678ee cl-statistics-1.0.0.2.ebuild 1082
-MD5 8ad2cb94bdf6a7711c9b726dab72b82a ChangeLog 338
+MD5 44531bc3a4857c6d99ed163bafe323e5 cl-statistics-1.0.0.2.ebuild 1082
+MD5 e0c5216eddff2ee0cb84670143395c33 ChangeLog 516
MD5 e7179b4c698de3d0d5630409d400a504 cl-statistics-1.0.0.1.ebuild 760
MD5 a9cba10a5762d6f7da111f3ec126c9ac files/digest-cl-statistics-1.0.0.1 77
MD5 18de310292b70deeb144e5b3328f858b files/cl-statistics.asd 1089
diff --git a/dev-lisp/cl-statistics/cl-statistics-1.0.0.2.ebuild b/dev-lisp/cl-statistics/cl-statistics-1.0.0.2.ebuild
new file mode 100644
index 000000000000..9d815058b68b
--- /dev/null
+++ b/dev-lisp/cl-statistics/cl-statistics-1.0.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-statistics/cl-statistics-1.0.0.2.ebuild,v 1.1 2003/10/17 16:59:40 mkennedy Exp $
+
+inherit common-lisp
+
+DEB_PV=1
+
+DESCRIPTION="Common Lisp Statistics Package"
+HOMEPAGE="http://www.biolisp.org
+ http://packages.debian.org/unstable/devel/cl-statistics.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-statistics/${PN}_${PV}.orig.tar.gz
+ http://ftp.debian.org/debian/pool/main/c/cl-statistics/${PN}_${PV}-${DEB_PV}.diff.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=cl-statistics
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${PN}_${PV}-${DEB_PV}.diff
+}
+
+src_install() {
+ common-lisp-install *.lisp ${FILESDIR}/${PN}.asd
+ common-lisp-system-symlink
+ dodoc *.txt
+ do-debian-credits
+}
+
+pkg_preinst() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
+
+pkg_postrm() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
diff --git a/dev-lisp/cl-statistics/files/digest-cl-statistics-1.0.0.2 b/dev-lisp/cl-statistics/files/digest-cl-statistics-1.0.0.2
new file mode 100644
index 000000000000..a21cd33a5417
--- /dev/null
+++ b/dev-lisp/cl-statistics/files/digest-cl-statistics-1.0.0.2
@@ -0,0 +1,2 @@
+MD5 3c0d682f297b74adc7ffb3a3ac014000 cl-statistics_1.0.0.2.orig.tar.gz 48444
+MD5 4fc9222742a8826984dfbc33d7592d79 cl-statistics_1.0.0.2-1.diff.gz 3994
diff --git a/dev-lisp/cl-statistics/metadata.xml b/dev-lisp/cl-statistics/metadata.xml
new file mode 100644
index 000000000000..f418045b09c8
--- /dev/null
+++ b/dev-lisp/cl-statistics/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+</pkgmetadata>
diff --git a/dev-lisp/cl-ubf/ChangeLog b/dev-lisp/cl-ubf/ChangeLog
index 6aa0c6055c1f..2f1dbe18fb6a 100644
--- a/dev-lisp/cl-ubf/ChangeLog
+++ b/dev-lisp/cl-ubf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lisp/cl-ubf
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-ubf/ChangeLog,v 1.1 2003/10/06 11:45:13 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-ubf/ChangeLog,v 1.2 2003/10/17 17:03:13 mkennedy Exp $
+
+ 17 Oct 2003; Matthew Kennedy <mkennedy@gentoo.org> cl-ubf-0.2.1.ebuild,
+ metadata.xml:
+ preinst, postrm
*cl-ubf-0.2.1 (05 Oct 2003)
diff --git a/dev-lisp/cl-ubf/Manifest b/dev-lisp/cl-ubf/Manifest
index d33e26666dd2..84a7678c7d49 100644
--- a/dev-lisp/cl-ubf/Manifest
+++ b/dev-lisp/cl-ubf/Manifest
@@ -1,3 +1,4 @@
-MD5 c5a027fd46bc1d3ffec9c802b35466f1 ChangeLog 315
-MD5 e90196cdc57810ee7ca62f2fba0846cd cl-ubf-0.2.1.ebuild 739
+MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
+MD5 5938ba97a956dc7933b82fb941fef4dd ChangeLog 424
+MD5 45ee1a6e1cb69b47cae336baf233de8b cl-ubf-0.2.1.ebuild 880
MD5 21f9d0fbbfe27c46881fac3a78dcc352 files/digest-cl-ubf-0.2.1 59
diff --git a/dev-lisp/cl-ubf/cl-ubf-0.2.1.ebuild b/dev-lisp/cl-ubf/cl-ubf-0.2.1.ebuild
index b6008fac8f04..3f6d0b1691d1 100644
--- a/dev-lisp/cl-ubf/cl-ubf-0.2.1.ebuild
+++ b/dev-lisp/cl-ubf/cl-ubf-0.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-ubf/cl-ubf-0.2.1.ebuild,v 1.1 2003/10/06 11:45:13 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-ubf/cl-ubf-0.2.1.ebuild,v 1.2 2003/10/17 17:03:13 mkennedy Exp $
inherit common-lisp
@@ -24,3 +24,11 @@ src_install() {
common-lisp-install *.lisp *.asd
common-lisp-system-symlink
}
+
+pkg_preinst() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
+
+pkg_postrm() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
diff --git a/dev-lisp/cl-ubf/metadata.xml b/dev-lisp/cl-ubf/metadata.xml
new file mode 100644
index 000000000000..f418045b09c8
--- /dev/null
+++ b/dev-lisp/cl-ubf/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+</pkgmetadata>