summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-03-18 02:55:33 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-03-18 02:55:33 +0000
commit23b57ea67d5ee7e39c96c72159e26fa84b5a1f10 (patch)
tree9f7143cdd1125c8a6d15981a57deefc565974dac /dev-lua
parentamd64 stable - 504890 (diff)
downloadgentoo-2-23b57ea67d5ee7e39c96c72159e26fa84b5a1f10.tar.gz
gentoo-2-23b57ea67d5ee7e39c96c72159e26fa84b5a1f10.tar.bz2
gentoo-2-23b57ea67d5ee7e39c96c72159e26fa84b5a1f10.zip
Cleanup old. Fixes bug #500252.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luadbi/ChangeLog6
-rw-r--r--dev-lua/luadbi/files/0.5-postgres-path.patch9
-rw-r--r--dev-lua/luadbi/luadbi-0.5-r3.ebuild65
3 files changed, 5 insertions, 75 deletions
diff --git a/dev-lua/luadbi/ChangeLog b/dev-lua/luadbi/ChangeLog
index 7c8039432951..9f0118a5a5e3 100644
--- a/dev-lua/luadbi/ChangeLog
+++ b/dev-lua/luadbi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lua/luadbi
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lua/luadbi/ChangeLog,v 1.23 2014/03/12 05:25:21 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luadbi/ChangeLog,v 1.24 2014/03/18 02:55:33 mrueg Exp $
+
+ 18 Mar 2014; Manuel Rüger <mrueg@gentoo.org> -files/0.5-postgres-path.patch,
+ -luadbi-0.5-r3.ebuild:
+ Cleanup old. Fixes bug #500252.
09 Mar 2014; Pawel Hajdan jr <phajdan.jr@gentoo.org> luadbi-0.5-r5.ebuild:
x86 stable wrt bug #503278
diff --git a/dev-lua/luadbi/files/0.5-postgres-path.patch b/dev-lua/luadbi/files/0.5-postgres-path.patch
deleted file mode 100644
index 87a0e889a582..000000000000
--- a/dev-lua/luadbi/files/0.5-postgres-path.patch
+++ /dev/null
@@ -1,9 +0,0 @@
---- dbd/postgresql/dbd_postgresql.h.old 2010-05-01 06:25:12.000000000 +0200
-+++ dbd/postgresql/dbd_postgresql.h 2011-04-19 16:59:53.364944209 +0200
-@@ -1,5 +1,5 @@
- #include <libpq-fe.h>
--#include <postgres_fe.h>
-+#include <server/postgres_fe.h>
- #include <dbd/common.h>
-
- /* \ No newline at end of file
diff --git a/dev-lua/luadbi/luadbi-0.5-r3.ebuild b/dev-lua/luadbi/luadbi-0.5-r3.ebuild
deleted file mode 100644
index 710a6ae73fc1..000000000000
--- a/dev-lua/luadbi/luadbi-0.5-r3.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lua/luadbi/luadbi-0.5-r3.ebuild,v 1.4 2014/01/18 18:41:15 pacho Exp $
-
-EAPI=5
-
-inherit toolchain-funcs flag-o-matic eutils
-
-DESCRIPTION="DBI module for Lua"
-HOMEPAGE="http://code.google.com/p/luadbi/"
-SRC_URI="http://luadbi.googlecode.com/files/${PN}.${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86"
-IUSE="mysql postgres sqlite"
-REQUIRED_USE="|| ( mysql postgres sqlite )"
-
-RDEPEND=">=dev-lang/lua-5.1
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql-base )
- sqlite? ( >=dev-db/sqlite-3 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S="${WORKDIR}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PV}-r2-Makefile.patch \
- "${FILESDIR}"/${PV}-postgres-path.patch
- sed -i -e "s#^INSTALL_DIR_LUA=.*#INSTALL_DIR_LUA=$(pkg-config --variable INSTALL_LMOD lua)#" \
- -e "s#^INSTALL_DIR_BIN=.*#INSTALL_DIR_BIN=$(pkg-config --variable INSTALL_CMOD lua)#" \
- -e "s#^LUA_INC_DIR=.*#LUA_INC_DIR=$(pkg-config --variable INSTALL_INC lua)#" \
- -e "s#^LUA_LIB_DIR=.*#LUA_LIB_DIR=$(pkg-config --variable INSTALL_LIB lua)#" \
- -e "s#^LUA_LIB =.*#LUA_LIB=lua#" Makefile || die
-
- drivers=""
-
- if use mysql; then
- drivers+="mysql "
- sed -i -e "s#^\(INCLUDES.*\)#\1 $(mysql_config --include)#" \
- -e "s#^\(MYSQL_LDFLAGS=\$(COMMON_LDFLAGS)\).*#\1 $(mysql_config --libs)#" Makefile || die
- fi
-
- if use postgres; then
- drivers+="psql "
- sed -i -e "s#^\(INCLUDES.*\)#\1 -I$(pg_config --includedir)#" \
- -e "s#^\(PSQL_LDFLAGS=\$(COMMON_LDFLAGS)\).*#\1 -L$(pg_config --libdir) -lpq#" Makefile || die
- fi
-
- use sqlite && drivers+="sqlite3"
-}
-
-src_compile() {
- append-flags -fPIC
- for driver in ${drivers}; do
- emake CC="$(tc-getCC)" COMMON_LDFLAGS="${LDFLAGS}" ${driver}
- done
-}
-
-src_install() {
- for driver in ${drivers}; do
- emake DESTDIR="${D}" "install_${driver// /}"
- done
-}