summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-05-24 17:15:21 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-05-24 17:15:21 +0000
commit2bd84545758e4841658c65abc7128bb571c766f6 (patch)
tree2375f2c82c76903c99688184a8f08774e4f8b120 /dev-ml/async
parentversion bump (diff)
downloadgentoo-2-2bd84545758e4841658c65abc7128bb571c766f6.tar.gz
gentoo-2-2bd84545758e4841658c65abc7128bb571c766f6.tar.bz2
gentoo-2-2bd84545758e4841658c65abc7128bb571c766f6.zip
version bump
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/async')
-rw-r--r--dev-ml/async/ChangeLog7
-rw-r--r--dev-ml/async/async-109.22.00.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-ml/async/ChangeLog b/dev-ml/async/ChangeLog
index 31b1bc04eda4..0998cf573297 100644
--- a/dev-ml/async/ChangeLog
+++ b/dev-ml/async/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/async
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/async/ChangeLog,v 1.1 2013/03/06 17:20:15 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/async/ChangeLog,v 1.2 2013/05/24 17:15:21 aballier Exp $
+
+*async-109.22.00 (24 May 2013)
+
+ 24 May 2013; Alexis Ballier <aballier@gentoo.org> +async-109.22.00.ebuild:
+ version bump
*async-109.11.00 (06 Mar 2013)
diff --git a/dev-ml/async/async-109.22.00.ebuild b/dev-ml/async/async-109.22.00.ebuild
new file mode 100644
index 000000000000..316ed6e43843
--- /dev/null
+++ b/dev-ml/async/async-109.22.00.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/async/async-109.22.00.ebuild,v 1.1 2013/05/24 17:15:21 aballier Exp $
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Jane Street Capital's asynchronous execution library"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV}/individual/${MY_P}.tar.gz
+ http://dev.gentoo.org/~aballier/distfiles/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-4.00.0:=
+ >=dev-ml/async_core-109.22.00:=
+ >=dev-ml/async_unix-109.21.00:=
+ >=dev-ml/async_extra-109.22.00:=
+ "
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.0.2 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}