summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-06-30 13:10:13 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-06-30 13:10:13 +0000
commit8e1305d09070d571d1b749976df98e848ef668bb (patch)
tree1db85aa03f8d1d5c5c20628a8b21040d24bf4c43 /dev-ml/bin-prot
parentmask new bin-prot (diff)
downloadgentoo-2-8e1305d09070d571d1b749976df98e848ef668bb.tar.gz
gentoo-2-8e1305d09070d571d1b749976df98e848ef668bb.tar.bz2
gentoo-2-8e1305d09070d571d1b749976df98e848ef668bb.zip
version bump
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/bin-prot')
-rw-r--r--dev-ml/bin-prot/ChangeLog7
-rw-r--r--dev-ml/bin-prot/bin-prot-108.00.01.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ml/bin-prot/ChangeLog b/dev-ml/bin-prot/ChangeLog
index 900ca54f591f..309ec8d0ed24 100644
--- a/dev-ml/bin-prot/ChangeLog
+++ b/dev-ml/bin-prot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/bin-prot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/ChangeLog,v 1.14 2012/03/27 21:29:02 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/ChangeLog,v 1.15 2012/06/30 13:10:13 aballier Exp $
+
+*bin-prot-108.00.01 (30 Jun 2012)
+
+ 30 Jun 2012; Alexis Ballier <aballier@gentoo.org> +bin-prot-108.00.01.ebuild:
+ version bump
27 Mar 2012; Alexis Ballier <aballier@gentoo.org> bin-prot-2.0.3.ebuild:
convert to oasis.eclass
diff --git a/dev-ml/bin-prot/bin-prot-108.00.01.ebuild b/dev-ml/bin-prot/bin-prot-108.00.01.ebuild
new file mode 100644
index 000000000000..e1ab8682a226
--- /dev/null
+++ b/dev-ml/bin-prot/bin-prot-108.00.01.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/bin-prot-108.00.01.ebuild,v 1.1 2012/06/30 13:10:13 aballier Exp $
+
+EAPI=3
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="A binary protocol generator"
+HOMEPAGE="http://ocaml.janestreet.com/?q=node/13"
+SRC_URI="http://bitbucket.org/yminsky/ocaml-core/downloads/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND=">=dev-ml/ounit-1.0.2
+ >=dev-ml/type-conv-3.0.5"
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base dev-texlive/texlive-latexextra )"
+
+DOCS=( "README" "Changelog" )
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ oasis_src_compile
+ if use doc ; then
+ cd "${S}/doc"
+ pdflatex README || die
+ pdflatex README || die
+ fi
+}
+
+src_install() {
+ oasis_src_install
+
+ if use doc; then
+ dodoc doc/README.pdf || die
+ fi
+}