summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-03-27 21:29:02 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-03-27 21:29:02 +0000
commit9f8cdb29520ef3b7cde8db56359af00c8ea91a65 (patch)
treec7d07bf01735050717365b09bbeb86e30fd81b6c /dev-ml/bin-prot
parentuse OASIS_BUILD_TESTS (diff)
downloadgentoo-2-9f8cdb29520ef3b7cde8db56359af00c8ea91a65.tar.gz
gentoo-2-9f8cdb29520ef3b7cde8db56359af00c8ea91a65.tar.bz2
gentoo-2-9f8cdb29520ef3b7cde8db56359af00c8ea91a65.zip
convert to oasis.eclass
(Portage version: 2.2.0_alpha95/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/bin-prot')
-rw-r--r--dev-ml/bin-prot/ChangeLog5
-rw-r--r--dev-ml/bin-prot/bin-prot-2.0.3.ebuild33
2 files changed, 11 insertions, 27 deletions
diff --git a/dev-ml/bin-prot/ChangeLog b/dev-ml/bin-prot/ChangeLog
index fbf37e99c433..900ca54f591f 100644
--- a/dev-ml/bin-prot/ChangeLog
+++ b/dev-ml/bin-prot/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/bin-prot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/ChangeLog,v 1.13 2012/02/26 13:51:56 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/ChangeLog,v 1.14 2012/03/27 21:29:02 aballier Exp $
+
+ 27 Mar 2012; Alexis Ballier <aballier@gentoo.org> bin-prot-2.0.3.ebuild:
+ convert to oasis.eclass
26 Feb 2012; Alexis Ballier <aballier@gentoo.org> bin-prot-2.0.3.ebuild:
dont assign EAPI twice, by Ulrich Müller in bug #405895
diff --git a/dev-ml/bin-prot/bin-prot-2.0.3.ebuild b/dev-ml/bin-prot/bin-prot-2.0.3.ebuild
index 33094cd11c37..93e07d590739 100644
--- a/dev-ml/bin-prot/bin-prot-2.0.3.ebuild
+++ b/dev-ml/bin-prot/bin-prot-2.0.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/bin-prot-2.0.3.ebuild,v 1.2 2012/02/26 13:51:56 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/bin-prot-2.0.3.ebuild,v 1.3 2012/03/27 21:29:02 aballier Exp $
EAPI=3
-inherit findlib eutils multilib
+inherit oasis
DESCRIPTION="A binary protocol generator"
HOMEPAGE="http://ocaml.janestreet.com/?q=node/13"
@@ -13,31 +13,17 @@ SRC_URI="http://www.janestreet.com/ocaml/${P}.tar.gz"
LICENSE="LGPL-2.1-linking-exception"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="debug doc +ocamlopt"
+IUSE="doc"
-RDEPEND=">=dev-lang/ocaml-3.12[ocamlopt?]
- dev-ml/findlib
- >=dev-ml/ounit-1.0.2
+RDEPEND=">=dev-ml/ounit-1.0.2
>=dev-ml/type-conv-2.3.0"
DEPEND="${RDEPEND}
- >=dev-ml/ounit-1.0.2
doc? ( virtual/latex-base dev-texlive/texlive-latexextra )"
-oasis_use_enable() {
- echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
-}
-
-src_configure() {
- ./configure --prefix usr \
- --libdir /usr/$(get_libdir) \
- --destdir "${D}" \
- $(oasis_use_enable debug debug) \
- $(oasis_use_enable ocamlopt is_native) \
- || die
-}
+DOCS=( "README.txt" "Changelog" )
src_compile() {
- emake || die
+ oasis_src_compile
if use doc ; then
cd "${S}/doc"
pdflatex README || die
@@ -45,14 +31,9 @@ src_compile() {
fi
}
-src_test() {
- LD_LIBRARY_PATH="${S}/_build/lib" emake test || die
-}
-
src_install() {
- findlib_src_install
+ oasis_src_install
- dodoc README.txt Changelog || die
if use doc; then
dodoc doc/README.pdf || die
fi