summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-15 23:57:35 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-15 23:57:35 +0000
commit3149e5ff579308c6ea5a74220079f6a715e0455e (patch)
tree4daf542430f3b4c282d0f054eb8e4fd1704fde8b /dev-ml/camlp5
parentRemoved 2300_USB-mount-extd-inq-cmd-fix.patch from 3.10.7 to avoid inconsiste... (diff)
downloadgentoo-2-3149e5ff579308c6ea5a74220079f6a715e0455e.tar.gz
gentoo-2-3149e5ff579308c6ea5a74220079f6a715e0455e.tar.bz2
gentoo-2-3149e5ff579308c6ea5a74220079f6a715e0455e.zip
version bump
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/camlp5')
-rw-r--r--dev-ml/camlp5/ChangeLog7
-rw-r--r--dev-ml/camlp5/camlp5-6.11.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/dev-ml/camlp5/ChangeLog b/dev-ml/camlp5/ChangeLog
index 8f5c643117c3..a497a0023342 100644
--- a/dev-ml/camlp5/ChangeLog
+++ b/dev-ml/camlp5/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/camlp5
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.73 2013/03/03 14:59:09 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.74 2013/08/15 23:57:35 aballier Exp $
+
+*camlp5-6.11 (15 Aug 2013)
+
+ 15 Aug 2013; Alexis Ballier <aballier@gentoo.org> +camlp5-6.11.ebuild:
+ version bump
03 Mar 2013; Alexis Ballier <aballier@gentoo.org> -camlp5-6.05.ebuild,
-camlp5-6.06.ebuild:
diff --git a/dev-ml/camlp5/camlp5-6.11.ebuild b/dev-ml/camlp5/camlp5-6.11.ebuild
new file mode 100644
index 000000000000..46100ab63e02
--- /dev/null
+++ b/dev-ml/camlp5/camlp5-6.11.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/camlp5-6.11.ebuild,v 1.1 2013/08/15 23:57:35 aballier Exp $
+
+EAPI="5"
+
+inherit multilib findlib eutils
+
+MY_P=${P%_p*}
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="http://pauillac.inria.fr/~ddr/camlp5/"
+SRC_URI="http://pauillac.inria.fr/~ddr/camlp5/distrib/src/${MY_P}.tgz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="doc +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.10:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+PATCHLEVEL=${PV#*_p}
+PATCHLIST=""
+
+if [ "${PATCHLEVEL}" != "${PV}" ] ; then
+ for (( i=1; i<=PATCHLEVEL; i++ )) ; do
+ SRC_URI="${SRC_URI}
+ http://pauillac.inria.fr/~ddr/camlp5/distrib/src/patch-${PV%_p*}-${i} -> ${MY_P}-patch-${i}.patch"
+ PATCHLIST="${PATCHLIST} ${MY_P}-patch-${i}.patch"
+ done
+fi
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ for i in ${PATCHLIST} ; do
+ epatch "${DISTDIR}/${i}"
+ done
+}
+
+src_configure() {
+ ./configure \
+ --strict \
+ -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man || die "configure failed"
+}
+
+src_compile(){
+ emake out
+ if use ocamlopt; then
+ emake opt
+ emake opt.opt
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ # findlib support
+ insinto "$(ocamlfind printconf destdir)/${PN}"
+ doins etc/META
+
+ use doc && dohtml -r doc/*
+
+ dodoc CHANGES DEVEL ICHANGES README UPGRADING MODE
+}