summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-01-07 12:16:45 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-01-07 12:16:45 +0000
commitbb0d331e88e3886ebfcc74f950b38a5a6e0af688 (patch)
tree5ff47349c01d8309cac3628278928e4aae03cded /dev-ml/camlp5
parentremove old (diff)
downloadgentoo-2-bb0d331e88e3886ebfcc74f950b38a5a6e0af688.tar.gz
gentoo-2-bb0d331e88e3886ebfcc74f950b38a5a6e0af688.tar.bz2
gentoo-2-bb0d331e88e3886ebfcc74f950b38a5a6e0af688.zip
version bump
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'dev-ml/camlp5')
-rw-r--r--dev-ml/camlp5/ChangeLog9
-rw-r--r--dev-ml/camlp5/camlp5-5.11.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/dev-ml/camlp5/ChangeLog b/dev-ml/camlp5/ChangeLog
index 37ed9d7c1719..ba954723063b 100644
--- a/dev-ml/camlp5/ChangeLog
+++ b/dev-ml/camlp5/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/camlp5
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.29 2008/10/16 14:35:08 aballier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.30 2009/01/07 12:16:45 aballier Exp $
+
+*camlp5-5.11 (07 Jan 2009)
+
+ 07 Jan 2009; Alexis Ballier <aballier@gentoo.org> +camlp5-5.11.ebuild:
+ version bump
*camlp5-5.10 (16 Oct 2008)
diff --git a/dev-ml/camlp5/camlp5-5.11.ebuild b/dev-ml/camlp5/camlp5-5.11.ebuild
new file mode 100644
index 000000000000..7fe587a5f73c
--- /dev/null
+++ b/dev-ml/camlp5/camlp5-5.11.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/camlp5-5.11.ebuild,v 1.1 2009/01/07 12:16:45 aballier Exp $
+
+EAPI="2"
+
+inherit multilib findlib eutils
+
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="http://pauillac.inria.fr/~ddr/camlp5/"
+SRC_URI="http://pauillac.inria.fr/~ddr/camlp5/distrib/src/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="doc +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ ./configure \
+ -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man || die "configure failed"
+}
+
+src_compile(){
+ emake -j1 || die "emake failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "Compiling native code programs failed"
+ emake -j1 opt.opt || die "Compiling native code programs failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ # findlib support
+ insinto "$(ocamlfind printconf destdir)/${PN}"
+ doins etc/META || die "failed to install META file for findlib support"
+
+ use doc && dohtml -r doc/*
+
+ dodoc CHANGES DEVEL ICHANGES README UPGRADING MODE
+}