summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-10-28 08:29:16 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-10-28 08:29:16 +0000
commit8eec3842f44c71914bdf46a6149544f654a5480a (patch)
treec1d6caefcfbac15ac0d8d7c98b5e721733d6239a /dev-ml/dose3
parentversion bump (diff)
downloadgentoo-2-8eec3842f44c71914bdf46a6149544f654a5480a.tar.gz
gentoo-2-8eec3842f44c71914bdf46a6149544f654a5480a.tar.bz2
gentoo-2-8eec3842f44c71914bdf46a6149544f654a5480a.zip
initial import, ebuild by me
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/dose3')
-rw-r--r--dev-ml/dose3/ChangeLog10
-rw-r--r--dev-ml/dose3/dose3-3.3_beta2.ebuild50
-rw-r--r--dev-ml/dose3/metadata.xml10
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-ml/dose3/ChangeLog b/dev-ml/dose3/ChangeLog
new file mode 100644
index 000000000000..a9fb3e63884d
--- /dev/null
+++ b/dev-ml/dose3/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ml/dose3
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/dose3/ChangeLog,v 1.1 2014/10/28 08:29:16 aballier Exp $
+
+*dose3-3.3_beta2 (28 Oct 2014)
+
+ 28 Oct 2014; Alexis Ballier <aballier@gentoo.org> +dose3-3.3_beta2.ebuild,
+ +metadata.xml:
+ initial import, ebuild by me
+
diff --git a/dev-ml/dose3/dose3-3.3_beta2.ebuild b/dev-ml/dose3/dose3-3.3_beta2.ebuild
new file mode 100644
index 000000000000..36ccc230f105
--- /dev/null
+++ b/dev-ml/dose3/dose3-3.3_beta2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/dose3/dose3-3.3_beta2.ebuild,v 1.1 2014/10/28 08:29:16 aballier Exp $
+
+EAPI=5
+
+MY_P="${P/_beta/-beta}"
+DESCRIPTION="Library and a collection of tools to perform la large spectrum of analysis on package repositories"
+HOMEPAGE="http://dose.gforge.inria.fr/public_html/"
+SRC_URI="https://gforge.inria.fr/frs/download.php/file/34180/${MY_P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt +parmap zip bzip2 xml curl rpm4"
+
+RDEPEND="
+ >=dev-lang/ocaml-3.12:=[ocamlopt?]
+ dev-ml/cudf:=
+ dev-ml/extlib:=
+ dev-ml/ocaml-re:=
+ parmap? ( dev-ml/parmap:= )
+ zip? ( dev-ml/camlzip:= )
+ bzip2? ( dev-ml/camlbz2:= )
+ >=dev-ml/ocamlgraph-1.8.5:=
+ xml? ( || ( dev-ml/ocaml-expat:= dev-ml/xml-light:= ) )
+ curl? ( dev-ml/ocurl:= )
+ rpm4? ( app-arch/rpm )
+"
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf \
+ $(use_with !ocamlopt bytecodeonly) \
+ $(use parmap && echo "--with-parmap") \
+ $(use zip && echo "--with-zip") \
+ $(use bzip2 && echo "--with-bz2") \
+ --with-ocamlgraph \
+ $(use xml && echo "--with-xml") \
+ $(use curl && echo "--with-curl") \
+ $(use rpm4 && echo "--with-rpm4")
+}
+
+src_compile() {
+ emake -j1
+}
diff --git a/dev-ml/dose3/metadata.xml b/dev-ml/dose3/metadata.xml
new file mode 100644
index 000000000000..f3dd19f62c3d
--- /dev/null
+++ b/dev-ml/dose3/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+ <use>
+ <flag name="parmap">Adds multi-core CPU support via <pkg>dev-ml/parmap</pkg>.</flag>
+ <flag name="zip">Adds support for handling zip files.</flag>
+ <flag name="rpm4">Adds support for handling rpm4 files.</flag>
+ </use>
+</pkgmetadata>