summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-05-08 11:14:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-05-08 11:14:29 +0000
commit833c2b4a87c7ec0c968927dd0ecb14757051333d (patch)
tree9555538aa03313278ee769e0f75c5596ae127617 /dev-ml/extlib
parentAdd multilib support (diff)
downloadgentoo-2-833c2b4a87c7ec0c968927dd0ecb14757051333d.tar.gz
gentoo-2-833c2b4a87c7ec0c968927dd0ecb14757051333d.tar.bz2
gentoo-2-833c2b4a87c7ec0c968927dd0ecb14757051333d.zip
version bump
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/extlib')
-rw-r--r--dev-ml/extlib/ChangeLog7
-rw-r--r--dev-ml/extlib/extlib-1.5.4.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-ml/extlib/ChangeLog b/dev-ml/extlib/ChangeLog
index 02f690dd67ee..18df835e9169 100644
--- a/dev-ml/extlib/ChangeLog
+++ b/dev-ml/extlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/extlib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/extlib/ChangeLog,v 1.23 2013/03/10 10:44:17 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/extlib/ChangeLog,v 1.24 2013/05/08 11:14:29 aballier Exp $
+
+*extlib-1.5.4 (08 May 2013)
+
+ 08 May 2013; Alexis Ballier <aballier@gentoo.org> +extlib-1.5.4.ebuild:
+ version bump
10 Mar 2013; Alexis Ballier <aballier@gentoo.org> extlib-1.5.3.ebuild:
eapi5: define subslot, slot dep on ocaml, remove useless || die
diff --git a/dev-ml/extlib/extlib-1.5.4.ebuild b/dev-ml/extlib/extlib-1.5.4.ebuild
new file mode 100644
index 000000000000..f72812c4761e
--- /dev/null
+++ b/dev-ml/extlib/extlib-1.5.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/extlib/extlib-1.5.4.ebuild,v 1.1 2013/05/08 11:14:29 aballier Exp $
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="Standard library extensions for O'Caml"
+HOMEPAGE="http://code.google.com/p/ocaml-extlib/"
+SRC_URI="http://ocaml-extlib.googlecode.com/files/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc +ocamlopt"
+
+src_compile() {
+ emake all
+ if use ocamlopt; then
+ emake opt
+ fi
+
+ if use doc; then
+ emake doc
+ fi
+}
+
+src_install () {
+ findlib_src_install
+
+ # install documentation
+ dodoc README.txt
+
+ if use doc; then
+ dohtml doc/*
+ fi
+}