summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-02 19:24:38 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-02 19:24:38 +0000
commit58d2b1c1bd076ea7cb7e7cf39c762e52e09cfe93 (patch)
tree9d2b7d02b392382d38ac9a17a4e64f6d7304895d /dev-ml/findlib
parentfindlib ocamlopt useflag (diff)
downloadgentoo-2-58d2b1c1bd076ea7cb7e7cf39c762e52e09cfe93.tar.gz
gentoo-2-58d2b1c1bd076ea7cb7e7cf39c762e52e09cfe93.tar.bz2
gentoo-2-58d2b1c1bd076ea7cb7e7cf39c762e52e09cfe93.zip
Add support to build without ocamlopt
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'dev-ml/findlib')
-rw-r--r--dev-ml/findlib/ChangeLog7
-rw-r--r--dev-ml/findlib/findlib-1.2.1.ebuild22
2 files changed, 23 insertions, 6 deletions
diff --git a/dev-ml/findlib/ChangeLog b/dev-ml/findlib/ChangeLog
index 0a6580e76a28..9513a204a956 100644
--- a/dev-ml/findlib/ChangeLog
+++ b/dev-ml/findlib/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/findlib
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/ChangeLog,v 1.26 2007/11/13 13:49:15 aballier Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/ChangeLog,v 1.27 2008/01/02 19:24:38 aballier Exp $
+
+ 02 Jan 2008; Alexis Ballier <aballier@gentoo.org> findlib-1.2.1.ebuild:
+ Add support to build without ocamlopt
*findlib-1.2.1 (13 Nov 2007)
diff --git a/dev-ml/findlib/findlib-1.2.1.ebuild b/dev-ml/findlib/findlib-1.2.1.ebuild
index e50801d7c491..bba03b990be4 100644
--- a/dev-ml/findlib/findlib-1.2.1.ebuild
+++ b/dev-ml/findlib/findlib-1.2.1.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/findlib-1.2.1.ebuild,v 1.1 2007/11/13 13:49:15 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/findlib-1.2.1.ebuild,v 1.2 2008/01/02 19:24:38 aballier Exp $
inherit multilib eutils
-IUSE="doc tk"
+EAPI="1"
+
+IUSE="doc +ocamlopt tk"
DESCRIPTION="OCaml tool to find/use non-standard packages."
HOMEPAGE="http://www.ocaml-programming.de/packages/"
@@ -29,6 +31,12 @@ pkg_setup()
eerror ""
die "Please make sure that ocaml is installed with tk support or remove the USE flag"
fi
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
}
src_compile() {
@@ -37,7 +45,13 @@ src_compile() {
-config ${ocamlfind_destdir}/findlib/findlib.conf || die "configure failed"
emake all || die
- emake opt || die # optimized code
+ if use ocamlopt; then
+ emake opt || die # optimized code
+ else
+ # If using bytecode we dont want to strip the binary as it would remove the
+ # bytecode and only leave ocamlrun...
+ export STRIP_MASK="*/bin/*"
+ fi
}
src_install() {