summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-02-03 01:27:18 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-02-03 01:27:18 +0000
commit0afd168c26546cc88707a3761c907877bf9d3204 (patch)
tree76f46a11b80cd38bba204f5ed96160b2944f5b9b /dev-ml/lablgtk/lablgtk-1.2.6.ebuild
parentVersion bump and minor fix. (diff)
downloadgentoo-2-0afd168c26546cc88707a3761c907877bf9d3204.tar.gz
gentoo-2-0afd168c26546cc88707a3761c907877bf9d3204.tar.bz2
gentoo-2-0afd168c26546cc88707a3761c907877bf9d3204.zip
Version bump and minor fix.
Diffstat (limited to 'dev-ml/lablgtk/lablgtk-1.2.6.ebuild')
-rw-r--r--dev-ml/lablgtk/lablgtk-1.2.6.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-ml/lablgtk/lablgtk-1.2.6.ebuild b/dev-ml/lablgtk/lablgtk-1.2.6.ebuild
new file mode 100644
index 000000000000..4b3b6b570836
--- /dev/null
+++ b/dev-ml/lablgtk/lablgtk-1.2.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgtk/lablgtk-1.2.6.ebuild,v 1.1 2004/02/03 01:27:08 mattam Exp $
+
+IUSE="gnome opengl"
+
+DESCRIPTION="Objective CAML interface for Gtk+"
+HOMEPAGE="http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/lablgtk.html"
+LICENSE="LGPL-2.1 as-is"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=dev-lang/ocaml-3.06
+ gnome? ( =gnome-base/libglade-0.17*
+ >=gnome-base/gnome-libs-1.4.1.7
+ media-libs/gdk-pixbuf )
+ opengl? ( >=dev-ml/lablgl-0.98
+ =x11-libs/gtkglarea-1.2* )"
+
+RDEPEND=${DEPEND}
+
+SRC_URI="http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/dist/lablgtk-${PV}.tar.gz"
+S=${WORKDIR}/${P}
+SLOT="1"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+Name="LablGTK"
+
+src_compile() {
+
+ local myconf="USE_DOTOPT=1 BINDIR=${D}/usr/bin INSTALLDIR=${D}/usr/lib/ocaml/lablgtk DLLDIR=${D}/usr/lib/ocaml/stublibs"
+
+ use gnome && myconf="$myconf USE_GNOME=1 USE_GLADE=1"
+ use opengl && myconf="$myconf USE_GL=1"
+
+ make configure $myconf || die "./configure failed"
+ make all opt || die
+}
+
+src_install () {
+ dodir /usr/bin /usr/lib/ocaml/lablgtk /usr/lib/ocaml/stublibs
+ make install || die
+ dosed /usr/bin/lablgtk
+ dodoc CHANGES COPYING README
+}
+