summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-10-06 20:23:26 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-10-06 20:23:26 +0000
commita8b377d83fff22ad80a56a89fa949f30957bdf93 (patch)
treeb26bf34d7d4edfa4ce073978ec6a148e4eae4ed3 /dev-ml/ocaml-data-notation
parentMask crystalspace-1.2 and cel-1.2 for wxGTK-2.6 removal wrt #330683 (diff)
downloadgentoo-2-a8b377d83fff22ad80a56a89fa949f30957bdf93.tar.gz
gentoo-2-a8b377d83fff22ad80a56a89fa949f30957bdf93.tar.bz2
gentoo-2-a8b377d83fff22ad80a56a89fa949f30957bdf93.zip
add file from upstream bug tracker by Sergei Lebedev to fix build with type-conv-3
(Portage version: 2.2.0_alpha62/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/ocaml-data-notation')
-rw-r--r--dev-ml/ocaml-data-notation/ChangeLog7
-rw-r--r--dev-ml/ocaml-data-notation/files/typeconv3.patch22
-rw-r--r--dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.6.ebuild8
3 files changed, 34 insertions, 3 deletions
diff --git a/dev-ml/ocaml-data-notation/ChangeLog b/dev-ml/ocaml-data-notation/ChangeLog
index 3b1bf57f81d5..6df5319d44cb 100644
--- a/dev-ml/ocaml-data-notation/ChangeLog
+++ b/dev-ml/ocaml-data-notation/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocaml-data-notation
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-data-notation/ChangeLog,v 1.4 2011/07/06 18:31:58 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-data-notation/ChangeLog,v 1.5 2011/10/06 20:23:26 aballier Exp $
+
+ 06 Oct 2011; Alexis Ballier <aballier@gentoo.org> +files/typeconv3.patch,
+ ocaml-data-notation-0.0.6.ebuild:
+ add file from upstream bug tracker by Sergei Lebedev to fix build with
+ type-conv-3
06 Jul 2011; Alexis Ballier <aballier@gentoo.org>
-ocaml-data-notation-0.0.3.ebuild, -ocaml-data-notation-0.0.4.ebuild:
diff --git a/dev-ml/ocaml-data-notation/files/typeconv3.patch b/dev-ml/ocaml-data-notation/files/typeconv3.patch
new file mode 100644
index 000000000000..5c64dfdd000c
--- /dev/null
+++ b/dev-ml/ocaml-data-notation/files/typeconv3.patch
@@ -0,0 +1,22 @@
+http://forge.ocamlcore.org/tracker/index.php?func=detail&aid=1033&group_id=148&atid=674
+Date: 2011-09-14 06:41
+Sender: Sergei Lebedev
+
+Index: ocaml-data-notation-0.0.6/src/pa_odn.ml
+===================================================================
+--- ocaml-data-notation-0.0.6.orig/src/pa_odn.ml
++++ ocaml-data-notation-0.0.6/src/pa_odn.ml
+@@ -31,6 +31,13 @@ open PreCast;;
+ open Ast;;
+ open Pa_type_conv;;
+
++module Gen = struct
++ include Gen
++ (* Compatibility functions, removed from type-conv > 2.3 *)
++ let idp _loc id = <:patt< $lid:id$ >>
++ let ide _loc id = <:expr< $lid:id$ >>
++end
++
+ let dbug =
+ prerr_endline
+ ;;
diff --git a/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.6.ebuild b/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.6.ebuild
index 19cc1d174453..530ef532e50a 100644
--- a/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.6.ebuild
+++ b/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.6.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.6.ebuild,v 1.1 2011/06/25 18:56:56 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.6.ebuild,v 1.2 2011/10/06 20:23:26 aballier Exp $
EAPI=3
-inherit findlib multilib
+inherit findlib multilib eutils
DESCRIPTION="This project uses type-conv to dump OCaml data structure using OCaml data notation"
HOMEPAGE="https://forge.ocamlcore.org/projects/odn"
@@ -21,6 +21,10 @@ DEPEND="${RDEPEND}
dev-ml/ounit[ocamlopt?]
dev-ml/ocaml-fileutils[ocamlopt?]"
+src_prepare() {
+ has_version '>=dev-ml/type-conv-3' && epatch "${FILESDIR}/typeconv3.patch"
+}
+
oasis_use_enable() {
echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
}