summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-06-03 19:36:20 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-06-03 19:36:20 +0000
commite4afc244c704a390579dc9be271a1d8ffd87e5dc (patch)
treebae5dff8b75369864edbe220eb10a1776556fd9c /dev-ml/ocamlgsl
parentAdding dependency on netapi when client USE flag is enabled, bug #321483 (diff)
downloadgentoo-2-e4afc244c704a390579dc9be271a1d8ffd87e5dc.tar.gz
gentoo-2-e4afc244c704a390579dc9be271a1d8ffd87e5dc.tar.bz2
gentoo-2-e4afc244c704a390579dc9be271a1d8ffd87e5dc.zip
Initial import in the main tree from the sunrise overlay. Thanks Guillaume Horel for his work
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/ocamlgsl')
-rw-r--r--dev-ml/ocamlgsl/ChangeLog16
-rw-r--r--dev-ml/ocamlgsl/files/ocamlgsl-0.6.0-ocaml311.patch31
-rw-r--r--dev-ml/ocamlgsl/metadata.xml9
-rw-r--r--dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild37
4 files changed, 93 insertions, 0 deletions
diff --git a/dev-ml/ocamlgsl/ChangeLog b/dev-ml/ocamlgsl/ChangeLog
new file mode 100644
index 000000000000..9ac1aa5de521
--- /dev/null
+++ b/dev-ml/ocamlgsl/ChangeLog
@@ -0,0 +1,16 @@
+# ChangeLog for dev-ml/ocamlgsl
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgsl/ChangeLog,v 1.1 2010/06/03 19:36:20 bicatali Exp $
+
+*ocamlgsl-0.6.0 (03 Jun 2010)
+
+ 03 Jun 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ +ocamlgsl-0.6.0.ebuild, +files/ocamlgsl-0.6.0-ocaml311.patch,
+ +metadata.xml:
+ Initial import in the main tree from the sunrise overlay. Thanks Guillaume
+ Horel for his work
+
+ 17 Aug 2009; Guillaume Horel (thrasibule) <guillaume.horel@gmail.com>
+ +ocamlgsl-0.6.0.ebuild, +files/ocaml-3.11.patch, +metadata.xml:
+ New Ebuild for dev-ml/ocamlgsl (bug #280939)
+
diff --git a/dev-ml/ocamlgsl/files/ocamlgsl-0.6.0-ocaml311.patch b/dev-ml/ocamlgsl/files/ocamlgsl-0.6.0-ocaml311.patch
new file mode 100644
index 000000000000..52627ac24235
--- /dev/null
+++ b/dev-ml/ocamlgsl/files/ocamlgsl-0.6.0-ocaml311.patch
@@ -0,0 +1,31 @@
+ Makefile | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index ae12602..dd68657 100644
+--- a/Makefile
++++ b/Makefile
+@@ -16,12 +16,12 @@ OCPP := ocpp
+ FORT := fort
+ AWK := gawk
+
+-MNOCYGWIN ?= $(shell $(OCAMLC) -verbose foo.c 2>&1 | $(AWK) "NR==1 { print \$$3 }")
++MNOCYGWIN ?= $(shell $(OCAMLC) -verbose foo.c 2>&1 | $(AWK) 'NR==1 { print $3 }')
+ ifeq ($(MNOCYGWIN),-mnocygwin)
+ OCAML_BACKEND := mingw
+ endif
+
+-OCAML_BACKEND ?= $(shell $(OCAMLC) -verbose foo.c 2>&1 | $(AWK) "NR==1 { print \$$2 }")
++OCAML_BACKEND ?= $(shell $(OCAMLC) -verbose foo.c 2>&1 | $(AWK) 'NR==1 { print $2 }')
+ OCAML_VERSION ?= $(shell $(OCAMLC) -version)
+
+ OCAMLBCFLAGS := -g
+@@ -94,7 +94,7 @@ SRC := wrappers.h gsl_misc.ml io.h \
+ ifeq ($(OCAML_BACKEND),cl)
+ include msvc.mak
+ else
+-ifeq ($(OCAML_BACKEND),gcc)
++ifneq (,$(findstring gcc,$(OCAML_BACKEND)))
+ include gcc.mak
+ else
+ include mingw.mak
diff --git a/dev-ml/ocamlgsl/metadata.xml b/dev-ml/ocamlgsl/metadata.xml
new file mode 100644
index 000000000000..926da8de7a5f
--- /dev/null
+++ b/dev-ml/ocamlgsl/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang='en'>
+ This is an interface to GSL (GNU scientific library), for the
+ Objective Caml langage.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild b/dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild
new file mode 100644
index 000000000000..8899482c1f61
--- /dev/null
+++ b/dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild,v 1.1 2010/06/03 19:36:20 bicatali Exp $
+
+EAPI="2"
+
+inherit base findlib
+
+DESCRIPTION="OCaml bindings for the GSL library"
+HOMEPAGE="http://oandrieu.nerim.net/ocaml/gsl/"
+SRC_URI="http://oandrieu.nerim.net/ocaml/gsl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-lang/ocaml-3.10
+ sci-libs/gsl"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-ocaml311.patch" )
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ findlib_src_preinst
+ emake install-findlib || die "emake install failed"
+
+ dodoc README NEWS NOTES
+ doinfo *.info* || die "info install failed"
+ if use doc; then
+ dohtml doc/* || die "html docs install failed"
+ fi
+}