summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-07-05 23:10:06 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-07-05 23:10:06 +0000
commitd162fccf567743f21f30596eecea982b64857be3 (patch)
treebe6b85b7244e4ab3764f87e0dc37484a05bd809c /dev-ml/ocamlweb
parentInstall texmf files in the correct directory (diff)
downloadgentoo-2-d162fccf567743f21f30596eecea982b64857be3.tar.gz
gentoo-2-d162fccf567743f21f30596eecea982b64857be3.tar.bz2
gentoo-2-d162fccf567743f21f30596eecea982b64857be3.zip
revbump it to be sure everyone gets the changes
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/ocamlweb')
-rw-r--r--dev-ml/ocamlweb/ChangeLog7
-rw-r--r--dev-ml/ocamlweb/ocamlweb-1.38-r1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ml/ocamlweb/ChangeLog b/dev-ml/ocamlweb/ChangeLog
index c69368dd15a1..43ab2df030ef 100644
--- a/dev-ml/ocamlweb/ChangeLog
+++ b/dev-ml/ocamlweb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocamlweb
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlweb/ChangeLog,v 1.21 2013/07/05 23:08:05 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlweb/ChangeLog,v 1.22 2013/07/05 23:10:06 aballier Exp $
+
+*ocamlweb-1.38-r1 (05 Jul 2013)
+
+ 05 Jul 2013; Alexis Ballier <aballier@gentoo.org> +ocamlweb-1.38-r1.ebuild:
+ revbump it to be sure everyone gets the changes
05 Jul 2013; Alexis Ballier <aballier@gentoo.org> ocamlweb-1.38.ebuild:
Install texmf files in the correct directory
diff --git a/dev-ml/ocamlweb/ocamlweb-1.38-r1.ebuild b/dev-ml/ocamlweb/ocamlweb-1.38-r1.ebuild
new file mode 100644
index 000000000000..9253e0a6c352
--- /dev/null
+++ b/dev-ml/ocamlweb/ocamlweb-1.38-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlweb/ocamlweb-1.38-r1.ebuild,v 1.1 2013/07/05 23:10:06 aballier Exp $
+
+EAPI=5
+
+inherit latex-package eutils base
+
+DESCRIPTION="O'Caml literate programming tool"
+HOMEPAGE="http://www.lri.fr/~filliatr/ocamlweb/"
+SRC_URI="http://www.lri.fr/~filliatr/ftp/ocamlweb/${P}.tar.gz"
+
+IUSE=""
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND=">=dev-lang/ocaml-3.09:=
+ virtual/latex-base
+ dev-texlive/texlive-latexextra
+ "
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.37-strip.patch"
+ )
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ emake UPDATETEX="" prefix="${D}/usr" MANDIR="${D}/usr/share/man" BASETEXDIR="${D}/${TEXMF}" install
+ dodoc README CHANGES
+}