summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-10-29 09:05:04 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-10-29 09:05:04 +0000
commitd4302ba9b5513a60f318b1af21ad74109bdd86b8 (patch)
tree6be9d9b3da5f4270ed93c1490b50b752e5ce5cb7 /dev-ml/opam
parentbump; update deps, currently doc build also fails and my need purging, tidy t... (diff)
downloadgentoo-2-d4302ba9b5513a60f318b1af21ad74109bdd86b8.tar.gz
gentoo-2-d4302ba9b5513a60f318b1af21ad74109bdd86b8.tar.bz2
gentoo-2-d4302ba9b5513a60f318b1af21ad74109bdd86b8.zip
initial import, ebuild by OGINO Masanori & Guillaume Horel in bug #497184 with some modifications by me
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/opam')
-rw-r--r--dev-ml/opam/ChangeLog11
-rw-r--r--dev-ml/opam/metadata.xml5
-rw-r--r--dev-ml/opam/opam-1.2.0.ebuild51
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-ml/opam/ChangeLog b/dev-ml/opam/ChangeLog
new file mode 100644
index 000000000000..ea9ad61840c1
--- /dev/null
+++ b/dev-ml/opam/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ml/opam
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/opam/ChangeLog,v 1.1 2014/10/29 09:05:04 aballier Exp $
+
+*opam-1.2.0 (29 Oct 2014)
+
+ 29 Oct 2014; Alexis Ballier <aballier@gentoo.org> +opam-1.2.0.ebuild,
+ +metadata.xml:
+ initial import, ebuild by OGINO Masanori & Guillaume Horel in bug #497184
+ with some modifications by me
+
diff --git a/dev-ml/opam/metadata.xml b/dev-ml/opam/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/opam/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/opam/opam-1.2.0.ebuild b/dev-ml/opam/opam-1.2.0.ebuild
new file mode 100644
index 000000000000..24179f631272
--- /dev/null
+++ b/dev-ml/opam/opam-1.2.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/opam/opam-1.2.0.ebuild,v 1.1 2014/10/29 09:05:04 aballier Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A source-based package manager for OCaml"
+HOMEPAGE="http://opam.ocaml.org/"
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+if [[ ${PV} != 9999 ]]; then
+ SRC_URI="https://github.com/ocaml/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ocaml/opam.git"
+fi
+
+DEPEND="dev-lang/ocaml:=
+ || ( net-misc/wget net-misc/curl )
+ dev-ml/extlib:=
+ dev-ml/ocaml-re:=
+ dev-ml/ocamlgraph:=
+ dev-ml/cmdliner:=
+ dev-ml/cudf:=
+ dev-ml/dose3:=
+ dev-ml/uutf:=
+ dev-ml/jsonm:=
+"
+RDEPEND="${DEPEND}
+ dev-ml/findlib
+"
+
+src_compile() {
+ emake -j1
+ cd doc
+ emake man
+}
+
+src_test() {
+ EMAIL=foo@bar.com emake -j1 tests
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" OPAMINSTALLER_FLAGS="--prefix=\"${ED}/usr\" --libdir=\"${D}/$(ocamlc -where)\"" libinstall
+}