summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-03-28 15:35:38 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-03-28 15:35:38 +0000
commit13d87975a169738dd3ee0156545c73ba21707d06 (patch)
tree70cfafb89c4fa09fe2e5e387c86acc184b35391a /dev-ml
parentRemove old 040 revision. (diff)
downloadgentoo-2-13d87975a169738dd3ee0156545c73ba21707d06.tar.gz
gentoo-2-13d87975a169738dd3ee0156545c73ba21707d06.tar.bz2
gentoo-2-13d87975a169738dd3ee0156545c73ba21707d06.zip
version bump
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/postgresql-ocaml/ChangeLog8
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-3.2.0.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ml/postgresql-ocaml/ChangeLog b/dev-ml/postgresql-ocaml/ChangeLog
index 6061486ac453..ad8f00466ec0 100644
--- a/dev-ml/postgresql-ocaml/ChangeLog
+++ b/dev-ml/postgresql-ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/postgresql-ocaml
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.44 2015/02/02 09:39:35 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.45 2015/03/28 15:35:38 aballier Exp $
+
+*postgresql-ocaml-3.2.0 (28 Mar 2015)
+
+ 28 Mar 2015; Alexis Ballier <aballier@gentoo.org>
+ +postgresql-ocaml-3.2.0.ebuild:
+ version bump
*postgresql-ocaml-3.0.0 (02 Feb 2015)
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-3.2.0.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-3.2.0.ebuild
new file mode 100644
index 000000000000..946dd5551336
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-3.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/postgresql-ocaml-3.2.0.ebuild,v 1.1 2015/03/28 15:35:38 aballier Exp $
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases"
+SRC_URI="https://github.com/mmottl/postgresql-ocaml/releases/download/v${PV}/${P}.tar.gz"
+HOMEPAGE="http://mmottl.github.io/postgresql-ocaml/"
+IUSE="examples"
+
+RDEPEND="
+ dev-db/postgresql:=[server]
+"
+DEPEND="${RDEPEND}
+ >=dev-ml/findlib-1.5"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}