summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-02-09 14:37:04 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-02-09 14:37:04 +0000
commit3c68d524db21f20f44f0d08d054258f6a3c417fa (patch)
treec7592881cbee9dd282bf61bd5fd6237f0df519f4 /dev-ml
parentAdd missing slot operator for dev-lang/perl (diff)
downloadgentoo-2-3c68d524db21f20f44f0d08d054258f6a3c417fa.tar.gz
gentoo-2-3c68d524db21f20f44f0d08d054258f6a3c417fa.tar.bz2
gentoo-2-3c68d524db21f20f44f0d08d054258f6a3c417fa.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.16/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlnet/ChangeLog9
-rw-r--r--dev-ml/ocamlnet/ocamlnet-4.0.1.ebuild78
2 files changed, 85 insertions, 2 deletions
diff --git a/dev-ml/ocamlnet/ChangeLog b/dev-ml/ocamlnet/ChangeLog
index 8135735c6dc0..79175576ced8 100644
--- a/dev-ml/ocamlnet/ChangeLog
+++ b/dev-ml/ocamlnet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocamlnet
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.84 2014/11/28 17:10:46 aballier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.85 2015/02/09 14:37:04 aballier Exp $
+
+*ocamlnet-4.0.1 (09 Feb 2015)
+
+ 09 Feb 2015; Alexis Ballier <aballier@gentoo.org> +ocamlnet-4.0.1.ebuild:
+ version bump
28 Nov 2014; Alexis Ballier <aballier@gentoo.org> ocamlnet-3.7.7.ebuild:
update deps for ocaml 4.02
diff --git a/dev-ml/ocamlnet/ocamlnet-4.0.1.ebuild b/dev-ml/ocamlnet/ocamlnet-4.0.1.ebuild
new file mode 100644
index 000000000000..149032ae5fac
--- /dev/null
+++ b/dev-ml/ocamlnet/ocamlnet-4.0.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-4.0.1.ebuild,v 1.1 2015/02/09 14:37:04 aballier Exp $
+
+EAPI="5"
+
+inherit eutils findlib
+
+MY_P=${P/_beta/test}
+DESCRIPTION="Modules for OCaml application-level Internet protocols"
+HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
+SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
+
+LICENSE="ZLIB GPL-2+"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="gtk kerberos tk httpd +ocamlopt +pcre ssl zip"
+RESTRICT="installsources"
+
+# the auth-dh compile flag has been disabled as well, since it depends on
+# ocaml-cryptgps, which is not available.
+
+RDEPEND=">=dev-ml/findlib-1.0
+ pcre? ( >=dev-ml/pcre-ocaml-5:= )
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ tk? ( || ( dev-ml/labltk:= <dev-lang/ocaml-4.02[tk] ) )
+ ssl? ( net-libs/gnutls:= )
+ gtk? ( >=dev-ml/lablgtk-2:= )
+ kerberos? ( virtual/krb5 )
+ zip? ( dev-ml/camlzip:= )
+ "
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${MY_P}
+
+ocamlnet_use_with() {
+ if use $1; then
+ echo "-with-$2"
+ else
+ echo "-without-$2"
+ fi
+}
+
+ocamlnet_use_enable() {
+ if use $1; then
+ echo "-enable-$2"
+ else
+ echo "-disable-$2"
+ fi
+}
+
+src_configure() {
+ ./configure \
+ -bindir /usr/bin \
+ -datadir /usr/share/${PN} \
+ $(ocamlnet_use_enable ssl gnutls) \
+ $(ocamlnet_use_enable gtk gtk2) \
+ $(ocamlnet_use_enable kerberos gssapi) \
+ $(ocamlnet_use_enable pcre pcre) \
+ $(ocamlnet_use_enable tk tcl) \
+ $(ocamlnet_use_enable zip zip) \
+ $(ocamlnet_use_with httpd nethttpd) \
+ || die "Error : econf failed!"
+}
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 opt
+ fi
+}
+
+src_install() {
+ export STRIP_MASK="*/bin/*"
+ findlib_src_install
+}