summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-03-05 17:46:09 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-03-05 17:46:09 +0000
commit3c6f3bac4739621dfcf6b9fd7a92e6a06919aeb8 (patch)
treed44de4fdf9464930442275a9126244150b600f30 /dev-ml
parentblock old ocaml versions (diff)
downloadgentoo-2-3c6f3bac4739621dfcf6b9fd7a92e6a06919aeb8.tar.gz
gentoo-2-3c6f3bac4739621dfcf6b9fd7a92e6a06919aeb8.tar.bz2
gentoo-2-3c6f3bac4739621dfcf6b9fd7a92e6a06919aeb8.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camlp4/ChangeLog7
-rw-r--r--dev-ml/camlp4/camlp4-4.02.1_p3.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ml/camlp4/ChangeLog b/dev-ml/camlp4/ChangeLog
index 4eceb37a5146..2ae7ac9b0df2 100644
--- a/dev-ml/camlp4/ChangeLog
+++ b/dev-ml/camlp4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/camlp4
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp4/ChangeLog,v 1.5 2015/03/05 17:30:58 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp4/ChangeLog,v 1.6 2015/03/05 17:46:09 aballier Exp $
+
+*camlp4-4.02.1_p3 (05 Mar 2015)
+
+ 05 Mar 2015; Alexis Ballier <aballier@gentoo.org> +camlp4-4.02.1_p3.ebuild:
+ version bump
05 Mar 2015; Alexis Ballier <aballier@gentoo.org> camlp4-4.02.1_p2.ebuild:
block old ocaml versions
diff --git a/dev-ml/camlp4/camlp4-4.02.1_p3.ebuild b/dev-ml/camlp4/camlp4-4.02.1_p3.ebuild
new file mode 100644
index 000000000000..a06141d6b61a
--- /dev/null
+++ b/dev-ml/camlp4/camlp4-4.02.1_p3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp4/camlp4-4.02.1_p3.ebuild,v 1.1 2015/03/05 17:46:09 aballier Exp $
+
+EAPI=5
+
+MY_PV=${PV/_p/+}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="System for writing extensible parsers for programming languages"
+HOMEPAGE="https://github.com/ocaml/camlp4"
+SRC_URI="https://github.com/ocaml/camlp4/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-fbsd ~x86-linux"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-4.02:=[ocamlopt?]"
+RDEPEND="${DEPEND}
+ !<dev-lang/ocaml-4.02
+ !<dev-ml/findlib-1.5.5-r1"
+
+S=${WORKDIR}/${P/_p/-}
+
+src_configure() {
+ ./configure \
+ --bindir="${EPREFIX}/usr/bin" \
+ --libdir="$(ocamlc -where)" \
+ --pkgdir="$(ocamlc -where)" \
+ || die
+}
+
+src_compile() {
+ emake byte
+ use ocamlopt && emake native
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-META
+ dodoc CHANGES.md README.md
+}