summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-09-28 18:57:18 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-09-28 18:57:18 +0000
commit4168d20a8dced0716fb2812346a08a2dcc7ff2e3 (patch)
tree5dce483f8f3d92edf7e71c985368101822248d7b /dev-ml
parentMask spca drivers for removal wrt #159176 because they are supported by in-ke... (diff)
downloadgentoo-2-4168d20a8dced0716fb2812346a08a2dcc7ff2e3.tar.gz
gentoo-2-4168d20a8dced0716fb2812346a08a2dcc7ff2e3.tar.bz2
gentoo-2-4168d20a8dced0716fb2812346a08a2dcc7ff2e3.zip
remove old
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/postgresql-ocaml/ChangeLog6
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-1.11.1.ebuild42
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-1.8.2.ebuild54
3 files changed, 5 insertions, 97 deletions
diff --git a/dev-ml/postgresql-ocaml/ChangeLog b/dev-ml/postgresql-ocaml/ChangeLog
index be0cfee3d963..7106691d4df0 100644
--- a/dev-ml/postgresql-ocaml/ChangeLog
+++ b/dev-ml/postgresql-ocaml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ml/postgresql-ocaml
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.11 2009/09/18 21:47:06 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.12 2009/09/28 18:57:18 aballier Exp $
+
+ 28 Sep 2009; Alexis Ballier <aballier@gentoo.org>
+ -postgresql-ocaml-1.8.2.ebuild, -postgresql-ocaml-1.11.1.ebuild:
+ remove old
*postgresql-ocaml-1.12.1 (18 Sep 2009)
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-1.11.1.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.11.1.ebuild
deleted file mode 100644
index cbe431814eed..000000000000
--- a/dev-ml/postgresql-ocaml/postgresql-ocaml-1.11.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/postgresql-ocaml-1.11.1.ebuild,v 1.1 2009/06/21 13:13:50 aballier Exp $
-
-EAPI="2"
-
-inherit findlib eutils
-
-IUSE="examples +ocamlopt"
-
-DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases."
-SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.gz"
-HOMEPAGE="http://ocaml.info/home/ocaml_sources.html#toc9"
-
-DEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
- >=virtual/postgresql-base-7.3
- >=virtual/postgresql-server-7.3"
-RDEPEND="${DEPEND}"
-
-SLOT="0"
-LICENSE="LGPL-2"
-KEYWORDS="~amd64 ~ppc ~x86"
-
-src_compile() {
- cd "${S}/lib"
- emake -j1 byte-code-library || die "failed to build byte code library"
- if use ocamlopt; then
- emake -j1 native-code-library || die "failed to built nativde code library"
- fi
-}
-
-src_install () {
- use ocamlopt || export OCAMLFIND_INSTFLAGS="-optional"
- findlib_src_preinst
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS Changelog README.txt
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-1.8.2.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.8.2.ebuild
deleted file mode 100644
index 6f58e4703145..000000000000
--- a/dev-ml/postgresql-ocaml/postgresql-ocaml-1.8.2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/postgresql-ocaml-1.8.2.ebuild,v 1.4 2009/06/21 12:59:02 aballier Exp $
-
-EAPI="1"
-
-inherit findlib eutils
-
-IUSE="examples +ocamlopt"
-
-DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases."
-SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.bz2"
-HOMEPAGE="http://ocaml.info/home/ocaml_sources.html#toc9"
-
-DEPEND=">=dev-lang/ocaml-3.09
- >=virtual/postgresql-base-7.3
- >=virtual/postgresql-server-7.3"
-RDEPEND="${DEPEND}"
-
-SLOT="0"
-LICENSE="LGPL-2"
-KEYWORDS="~amd64 ~ppc ~x86"
-
-pkg_setup() {
- if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
- eerror "In order to build ${PN} with native code support from ocaml"
- eerror "You first need to have a native code ocaml compiler."
- eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
- die "Please install ocaml with ocamlopt useflag"
- fi
-}
-
-src_compile() {
- cd "${S}/lib"
- emake -j1 byte-code-library || die "failed to build byte code library"
- if use ocamlopt; then
- emake -j1 native-code-library || die "failed to built nativde code library"
- fi
-}
-
-src_install () {
- use ocamlopt || export OCAMLFIND_INSTFLAGS="-optional"
- findlib_src_preinst
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS VERSION
-
- if use examples; then
- for dir in examples/*
- do
- docinto $dir
- dodoc $dir/*
- done
- fi
-}