summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2005-03-08 23:13:27 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2005-03-08 23:13:27 +0000
commit54d73694b924c1a51ecaa61ffa1d5508b17078ee (patch)
tree6d7d544980b80a3881c586944682465412d23159 /dev-ml
parentAdded new hmake version (diff)
downloadgentoo-2-54d73694b924c1a51ecaa61ffa1d5508b17078ee.tar.gz
gentoo-2-54d73694b924c1a51ecaa61ffa1d5508b17078ee.tar.bz2
gentoo-2-54d73694b924c1a51ecaa61ffa1d5508b17078ee.zip
Fix data files installation path and add pop library.
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlnet/ChangeLog5
-rw-r--r--dev-ml/ocamlnet/ocamlnet-0.98.ebuild10
2 files changed, 10 insertions, 5 deletions
diff --git a/dev-ml/ocamlnet/ChangeLog b/dev-ml/ocamlnet/ChangeLog
index 9ae67f803e4d..e1502fd1ecd7 100644
--- a/dev-ml/ocamlnet/ChangeLog
+++ b/dev-ml/ocamlnet/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/ocamlnet
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.10 2005/02/18 17:37:19 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.11 2005/03/08 23:13:27 mattam Exp $
+
+ 09 Mar 2005; Matthieu Sozeau <mattam@gentoo.org> ocamlnet-0.98.ebuild:
+ Fix data files installation, add pop library.
18 Feb 2005; Michael Sterrett <mr_bones_@gentoo.org> ocamlnet-0.98.ebuild:
fix repoman issues; tidy
diff --git a/dev-ml/ocamlnet/ocamlnet-0.98.ebuild b/dev-ml/ocamlnet/ocamlnet-0.98.ebuild
index 3990f502f430..387e85156e18 100644
--- a/dev-ml/ocamlnet/ocamlnet-0.98.ebuild
+++ b/dev-ml/ocamlnet/ocamlnet-0.98.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-0.98.ebuild,v 1.2 2005/02/18 17:37:19 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-0.98.ebuild,v 1.3 2005/03/08 23:13:27 mattam Exp $
inherit findlib
@@ -10,20 +10,22 @@ SRC_URI="mirror://sourceforge/ocamlnet/${P}.tar.gz"
LICENSE="as-is"
KEYWORDS="~ppc ~x86"
-SLOT=")"
+SLOT="0"
IUSE=""
DEPEND=">=dev-ml/pcre-ocaml-4.31.0"
S="${WORKDIR}/${P}/src"
+DATADIR=/usr/share/${PN}
+
src_compile() {
- ./configure || die "configure failed"
+ ./configure -with-pop -datadir ${DATADIR} || die "configure failed"
make all opt || die "make failed"
}
src_install() {
- findlib_src_install NET_DB_DIR="${D}${OCAML_SITELIB}/netstring"
+ findlib_src_install NET_DB_DIR="${D}${DATADIR}"
cd "${WORKDIR}/${P}"
dodoc README