summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-03-06 17:20:15 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-03-06 17:20:15 +0000
commit607ace1f8106c633977f41fc779e5d2969bc934f (patch)
treeec4d220727eea9b5423f3f5ed9e8c7e95055efb3 /dev-ml
parentDev channel bump. Remove old. (diff)
downloadgentoo-2-607ace1f8106c633977f41fc779e5d2969bc934f.tar.gz
gentoo-2-607ace1f8106c633977f41fc779e5d2969bc934f.tar.bz2
gentoo-2-607ace1f8106c633977f41fc779e5d2969bc934f.zip
initial import, ebuild by me
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/async/ChangeLog10
-rw-r--r--dev-ml/async/async-109.11.00.ebuild39
-rw-r--r--dev-ml/async/metadata.xml5
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-ml/async/ChangeLog b/dev-ml/async/ChangeLog
new file mode 100644
index 000000000000..31b1bc04eda4
--- /dev/null
+++ b/dev-ml/async/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ml/async
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/async/ChangeLog,v 1.1 2013/03/06 17:20:15 aballier Exp $
+
+*async-109.11.00 (06 Mar 2013)
+
+ 06 Mar 2013; Alexis Ballier <aballier@gentoo.org> +async-109.11.00.ebuild,
+ +metadata.xml:
+ initial import, ebuild by me
+
diff --git a/dev-ml/async/async-109.11.00.ebuild b/dev-ml/async/async-109.11.00.ebuild
new file mode 100644
index 000000000000..f91eea15ff02
--- /dev/null
+++ b/dev-ml/async/async-109.11.00.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/async/async-109.11.00.ebuild,v 1.1 2013/03/06 17:20:15 aballier Exp $
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Jane Street Capital's asynchronous execution library"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV}/individual/${MY_P}.tar.gz
+ http://dev.gentoo.org/~aballier/distfiles/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-4.00.0:=
+ >=dev-ml/async_core-${PV}:=
+ >=dev-ml/async_unix-${PV}:=
+ >=dev-ml/async_extra-${PV}:=
+ "
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.0.2 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-ml/async/metadata.xml b/dev-ml/async/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/async/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>