summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-19 15:44:49 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-19 15:44:49 +0000
commit63cfb2bc1911e0f162720c5d4fcc0ffe0674a90d (patch)
treeb2adb36993fe03144aa909561bcf492923b61cd1 /dev-ml
parentversion bump (diff)
downloadgentoo-2-63cfb2bc1911e0f162720c5d4fcc0ffe0674a90d.tar.gz
gentoo-2-63cfb2bc1911e0f162720c5d4fcc0ffe0674a90d.tar.bz2
gentoo-2-63cfb2bc1911e0f162720c5d4fcc0ffe0674a90d.zip
version bump
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/async/ChangeLog7
-rw-r--r--dev-ml/async/async-109.38.00.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-ml/async/ChangeLog b/dev-ml/async/ChangeLog
index eeaa6bbbdbea..b0c970214fa8 100644
--- a/dev-ml/async/ChangeLog
+++ b/dev-ml/async/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/async
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/async/ChangeLog,v 1.7 2013/08/16 23:02:35 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/async/ChangeLog,v 1.8 2013/08/19 15:44:49 aballier Exp $
+
+*async-109.38.00 (19 Aug 2013)
+
+ 19 Aug 2013; Alexis Ballier <aballier@gentoo.org> +async-109.38.00.ebuild:
+ version bump
16 Aug 2013; Alexis Ballier <aballier@gentoo.org> -async-109.27.00.ebuild,
-async-109.34.00.ebuild:
diff --git a/dev-ml/async/async-109.38.00.ebuild b/dev-ml/async/async-109.38.00.ebuild
new file mode 100644
index 000000000000..2b57e6d8eb25
--- /dev/null
+++ b/dev-ml/async/async-109.38.00.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/async/async-109.38.00.ebuild,v 1.1 2013/08/19 15:44:49 aballier Exp $
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Jane Street Capital's asynchronous execution library"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV}/individual/${MY_P}.tar.gz
+ http://dev.gentoo.org/~aballier/distfiles/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-4.00.0:=
+ >=dev-ml/async_core-${PV}:=
+ >=dev-ml/async_unix-${PV}:=
+ >=dev-ml/async_extra-${PV}:=
+ "
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.0.2 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}