summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-10-22 07:52:53 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-10-22 07:52:53 +0000
commit84d7f9210895ffaf3a15afcccb6d62be88ea8a68 (patch)
treec649838f4b0f43d50a9a7b3f7883645ea8136405 /dev-ml
parentInitial import of rspec-rails (diff)
downloadgentoo-2-84d7f9210895ffaf3a15afcccb6d62be88ea8a68.tar.gz
gentoo-2-84d7f9210895ffaf3a15afcccb6d62be88ea8a68.tar.bz2
gentoo-2-84d7f9210895ffaf3a15afcccb6d62be88ea8a68.zip
version bump
(Portage version: 2.2_rc12/cvs/Linux 2.6.27.2 x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlduce/ChangeLog8
-rw-r--r--dev-ml/ocamlduce/ocamlduce-3.10.2.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-ml/ocamlduce/ChangeLog b/dev-ml/ocamlduce/ChangeLog
index cdc86aa56173..6b8a276340f5 100644
--- a/dev-ml/ocamlduce/ChangeLog
+++ b/dev-ml/ocamlduce/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/ocamlduce
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlduce/ChangeLog,v 1.7 2008/09/25 12:25:35 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlduce/ChangeLog,v 1.8 2008/10/22 07:52:53 aballier Exp $
+
+*ocamlduce-3.10.2 (22 Oct 2008)
+
+ 22 Oct 2008; Alexis Ballier <aballier@gentoo.org>
+ +ocamlduce-3.10.2.ebuild:
+ version bump
25 Sep 2008; Alexis Ballier <aballier@gentoo.org> ocamlduce-3.10.0.ebuild:
keyword ~x86-fbsd
diff --git a/dev-ml/ocamlduce/ocamlduce-3.10.2.ebuild b/dev-ml/ocamlduce/ocamlduce-3.10.2.ebuild
new file mode 100644
index 000000000000..0f10c14fb420
--- /dev/null
+++ b/dev-ml/ocamlduce/ocamlduce-3.10.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlduce/ocamlduce-3.10.2.ebuild,v 1.1 2008/10/22 07:52:53 aballier Exp $
+
+inherit eutils findlib
+
+EAPI="2"
+
+MY_P="${P/_p/pl}"
+DESCRIPTION="OCamlDuce is a merger between OCaml and CDuce"
+HOMEPAGE="http://www.cduce.org/ocaml.html"
+SRC_URI="http://gallium.inria.fr/~frisch/ocamlcduce/download/${MY_P}.tar.gz"
+
+LICENSE="QPL-1.0 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
+ >=dev-ml/findlib-1.1.2"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ if use ocamlopt; then
+ emake -j1 all opt || die "emake failed"
+ else
+ emake CAMLC="ocamlc" CAMLDEP="ocamldep" -j1 all || die "emake failed"
+ fi
+}
+
+src_install() {
+ dodir /usr/bin
+ use ocamlopt && findlib_src_install BINDIR="${D}/usr/bin"
+ use ocamlopt || findlib_src_install BINDIR="${D}/usr/bin" CAMLC="ocamlc" CAMLDEP="ocamldep" OPT_VARIANTS=""
+}