summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-27 16:54:54 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-27 16:54:54 +0000
commit8bc0a2ce4bb8a1c45cfc0e20a0f8dc84514cb84b (patch)
tree2cf6bc4dff64b4dfa63fa26ab12750b8e57b302e /dev-ml
parentversion bump (diff)
downloadgentoo-2-8bc0a2ce4bb8a1c45cfc0e20a0f8dc84514cb84b.tar.gz
gentoo-2-8bc0a2ce4bb8a1c45cfc0e20a0f8dc84514cb84b.tar.bz2
gentoo-2-8bc0a2ce4bb8a1c45cfc0e20a0f8dc84514cb84b.zip
Install a META file, bug #482016 by Matthew Maurer. EAPI5, define subslot and add := dep on ocaml
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camlidl/ChangeLog11
-rw-r--r--dev-ml/camlidl/camlidl-1.05-r1.ebuild53
-rw-r--r--dev-ml/camlidl/files/META.camlidl5
3 files changed, 67 insertions, 2 deletions
diff --git a/dev-ml/camlidl/ChangeLog b/dev-ml/camlidl/ChangeLog
index 724ae0161f6a..02311f4eb27b 100644
--- a/dev-ml/camlidl/ChangeLog
+++ b/dev-ml/camlidl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ml/camlidl
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlidl/ChangeLog,v 1.6 2010/02/25 18:56:05 zmedico Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlidl/ChangeLog,v 1.7 2013/08/27 16:54:54 aballier Exp $
+
+*camlidl-1.05-r1 (27 Aug 2013)
+
+ 27 Aug 2013; Alexis Ballier <aballier@gentoo.org> +camlidl-1.05-r1.ebuild,
+ +files/META.camlidl:
+ Install a META file, bug #482016 by Matthew Maurer. EAPI5, define subslot and
+ add := dep on ocaml
25 Feb 2010; Zac Medico <zmedico@gentoo.org> camlidl-1.05.ebuild:
Bug #306677 - Fix invalid conditional USE dep.
diff --git a/dev-ml/camlidl/camlidl-1.05-r1.ebuild b/dev-ml/camlidl/camlidl-1.05-r1.ebuild
new file mode 100644
index 000000000000..4a8602431e37
--- /dev/null
+++ b/dev-ml/camlidl/camlidl-1.05-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlidl/camlidl-1.05-r1.ebuild,v 1.1 2013/08/27 16:54:54 aballier Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="CamlIDL is a stub code generator for using C/C++ libraries from O'Caml"
+HOMEPAGE="http://caml.inria.fr/camlidl/"
+SRC_URI="http://caml.inria.fr/distrib/bazar-ocaml/${P}.tar.gz"
+LICENSE="QPL-1.0 LGPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/tests.patch"
+ epatch "${FILESDIR}/includes.patch"
+}
+
+src_compile() {
+ # Use the UNIX makefile
+ libdir=`ocamlc -where`
+ sed -i -e "s|OCAMLLIB=.*|OCAMLLIB=${libdir}|" config/Makefile.unix
+ sed -i -e "s|BINDIR=.*|BINDIR=/usr/bin|" config/Makefile.unix
+ ln -s Makefile.unix config/Makefile
+
+ # Make
+ emake -j1
+}
+
+src_test() {
+ einfo "Running tests..."
+ cd tests
+ emake CCPP="$(tc-getCXX)"
+}
+
+src_install() {
+ libdir=`ocamlc -where`
+ dodir ${libdir}/caml
+ dodir /usr/bin
+ # Install
+ emake BINDIR="${ED}/usr/bin" OCAMLLIB="${ED}${libdir}" install
+
+ # Add package header
+ sed -e "s/@VERSION/${P}/g" "${FILESDIR}/META.camlidl" > "${ED}${libdir}/META.camlidl" || die
+
+ # Documentation
+ dodoc README Changes
+}
diff --git a/dev-ml/camlidl/files/META.camlidl b/dev-ml/camlidl/files/META.camlidl
new file mode 100644
index 000000000000..b0aeaf231415
--- /dev/null
+++ b/dev-ml/camlidl/files/META.camlidl
@@ -0,0 +1,5 @@
+description = "Stub generator"
+version = "@VERSION"
+directory = "^"
+archive(byte) = "com.cma"
+archive(native) = "com.cmxa"