summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-07-06 16:32:39 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-07-06 16:32:39 +0000
commit92485f5d356fd8395a25cb77a09db9c328c2b018 (patch)
tree395c68abf173f32e43c5c570efdb229e31bdb27d /dev-ml
parentFix udev rules.d directory from /etc/udev to /lib/udev. (diff)
downloadgentoo-2-92485f5d356fd8395a25cb77a09db9c328c2b018.tar.gz
gentoo-2-92485f5d356fd8395a25cb77a09db9c328c2b018.tar.bz2
gentoo-2-92485f5d356fd8395a25cb77a09db9c328c2b018.zip
build with ocaml-3.12.1
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlduce/ChangeLog8
-rw-r--r--dev-ml/ocamlduce/files/ocaml-3.12.1.patch13
-rw-r--r--dev-ml/ocamlduce/ocamlduce-3.12.0.0-r20.ebuild71
3 files changed, 91 insertions, 1 deletions
diff --git a/dev-ml/ocamlduce/ChangeLog b/dev-ml/ocamlduce/ChangeLog
index 08b170cabdac..b5893c6e5fc8 100644
--- a/dev-ml/ocamlduce/ChangeLog
+++ b/dev-ml/ocamlduce/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/ocamlduce
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlduce/ChangeLog,v 1.18 2011/06/26 20:00:52 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlduce/ChangeLog,v 1.19 2011/07/06 16:32:39 aballier Exp $
+
+*ocamlduce-3.12.0.0-r20 (06 Jul 2011)
+
+ 06 Jul 2011; Alexis Ballier <aballier@gentoo.org>
+ +ocamlduce-3.12.0.0-r20.ebuild, +files/ocaml-3.12.1.patch:
+ build with ocaml-3.12.1
*ocamlduce-3.12.0.0-r10 (26 Jun 2011)
diff --git a/dev-ml/ocamlduce/files/ocaml-3.12.1.patch b/dev-ml/ocamlduce/files/ocaml-3.12.1.patch
new file mode 100644
index 000000000000..15bfec61a7b6
--- /dev/null
+++ b/dev-ml/ocamlduce/files/ocaml-3.12.1.patch
@@ -0,0 +1,13 @@
+Index: work/ocamlduce-3.12.0.0/patches/typing.diff
+===================================================================
+--- work.orig/ocamlduce-3.12.0.0/patches/typing.diff
++++ work/ocamlduce-3.12.0.0/patches/typing.diff
+@@ -1987,7 +1987,7 @@ index ce84576..7b98d21 100644
+ @@ -106,6 +106,7 @@ and structure_item ppf tbl s =
+ | Pstr_class cdl -> List.iter (class_declaration ppf tbl) cdl;
+ | Pstr_class_type _ -> ()
+- | Pstr_include _ -> ()
++ | Pstr_include me -> module_expr ppf tbl me;
+ + | Pstr_namespace _ -> ()
+
+ and expression ppf tbl e =
diff --git a/dev-ml/ocamlduce/ocamlduce-3.12.0.0-r20.ebuild b/dev-ml/ocamlduce/ocamlduce-3.12.0.0-r20.ebuild
new file mode 100644
index 000000000000..a6a96d60289e
--- /dev/null
+++ b/dev-ml/ocamlduce/ocamlduce-3.12.0.0-r20.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlduce/ocamlduce-3.12.0.0-r20.ebuild,v 1.1 2011/07/06 16:32:39 aballier Exp $
+
+EAPI="2"
+
+inherit versionator eutils toolchain-funcs flag-o-matic multilib
+
+OCAML_VERSION=3.12.1
+OCAML_TARBALL=ocaml-${OCAML_VERSION}.tar.bz2
+OCAML_PATCHLEVEL=3
+OCAML_GENTOO_PATCHES=ocaml-patches-${OCAML_PATCHLEVEL}.tar.bz2
+
+DESCRIPTION="OCamlDuce is a merger between OCaml and CDuce"
+HOMEPAGE="http://ocamlduce.forge.ocamlcore.org/"
+SRC_URI="https://forge.ocamlcore.org/frs/download.php/441/${P}.tar.gz
+ ftp://ftp.inria.fr/INRIA/cristal/ocaml/ocaml-$(get_version_component_range 1-2 ${OCAML_VERSION})/${OCAML_TARBALL}
+ mirror://gentoo/${OCAML_GENTOO_PATCHES}"
+
+LICENSE="QPL-1.0 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="+ocamlopt"
+
+DEPEND="~dev-lang/ocaml-${OCAML_VERSION/+/_}[ocamlopt?]
+ >=dev-ml/findlib-1.2.4-r1
+ !!<dev-ml/${P}"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P}/ocaml-${OCAML_VERSION}
+
+src_unpack() {
+ unpack ${P}.tar.gz ${OCAML_GENTOO_PATCHES}
+}
+
+src_prepare() {
+ cd "${WORKDIR}/${P}"
+ epatch "${FILESDIR}/ocaml-${OCAML_VERSION}.patch"
+ emake OCAML_SOURCE="${DISTDIR}/${OCAML_TARBALL}" prepare || die "failed to prepare"
+ cd "${S}"
+ EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
+}
+
+src_configure() {
+ RAW_LDFLAGS="$(raw-ldflags)" ./configure -prefix /usr \
+ --bindir /usr/bin \
+ --libdir /usr/$(get_libdir)/ocaml \
+ --mandir /usr/share/man \
+ -host "${CHOST}" \
+ -cc "$(tc-getCC)" \
+ -as "$(tc-getAS)" \
+ -aspp "$(tc-getCC) -c" \
+ --with-pthread || die "configure failed!"
+}
+
+src_compile() {
+ if use ocamlopt; then
+ emake -f Makefile.ocamlduce -j1 world.opt || die
+ else
+ emake -f Makefile.ocamlduce -j1 world || die
+ fi
+}
+
+src_install() {
+ emake -f Makefile.ocamlduce BINDIR="${D}/usr/bin" LIBDIR="${D}/usr/$(get_libdir)/ocaml" installbyte || die
+ if use ocamlopt; then
+ emake -f Makefile.ocamlduce BINDIR="${D}/usr/bin" LIBDIR="${D}/usr/$(get_libdir)/ocaml" installopt || die
+ fi
+ dodoc Changes README
+}