summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-04-09 13:15:39 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-04-09 13:15:39 +0000
commitd5a26f47c6b9fe66753dcd355c230e4c181e2773 (patch)
treea3467f427fdc2d8fce3d0082ac320b248fe7a183 /dev-ml
parentversion bump (diff)
downloadgentoo-2-d5a26f47c6b9fe66753dcd355c230e4c181e2773.tar.gz
gentoo-2-d5a26f47c6b9fe66753dcd355c230e4c181e2773.tar.bz2
gentoo-2-d5a26f47c6b9fe66753dcd355c230e4c181e2773.zip
version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocurl/ChangeLog9
-rw-r--r--dev-ml/ocurl/ocurl-0.5.3.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/dev-ml/ocurl/ChangeLog b/dev-ml/ocurl/ChangeLog
index 9462c3984e5f..fdcec5166a6d 100644
--- a/dev-ml/ocurl/ChangeLog
+++ b/dev-ml/ocurl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocurl
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocurl/ChangeLog,v 1.8 2009/06/21 13:26:01 aballier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocurl/ChangeLog,v 1.9 2010/04/09 13:15:39 aballier Exp $
+
+*ocurl-0.5.3 (09 Apr 2010)
+
+ 09 Apr 2010; Alexis Ballier <aballier@gentoo.org> +ocurl-0.5.3.ebuild:
+ version bump
*ocurl-0.5.1 (21 Jun 2009)
diff --git a/dev-ml/ocurl/ocurl-0.5.3.ebuild b/dev-ml/ocurl/ocurl-0.5.3.ebuild
new file mode 100644
index 000000000000..231704361603
--- /dev/null
+++ b/dev-ml/ocurl/ocurl-0.5.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocurl/ocurl-0.5.3.ebuild,v 1.1 2010/04/09 13:15:39 aballier Exp $
+
+EAPI=2
+
+inherit eutils findlib autotools
+
+DESCRIPTION="OCaml interface to the libcurl library"
+HOMEPAGE="http://sourceforge.net/projects/ocurl"
+LICENSE="MIT"
+SRC_URI="mirror://sourceforge/ocurl/${P}.tgz"
+
+SLOT="0"
+IUSE="examples"
+
+DEPEND=">=net-misc/curl-7.9.8
+dev-libs/openssl"
+RDEPEND="$DEPEND"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.5.1-asneeded.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-findlib
+}
+
+src_compile()
+{
+ emake -j1 all || die
+}
+
+src_install()
+{
+ findlib_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}