summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-02-23 23:36:55 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-02-23 23:36:55 +0000
commitf3fc978595556b894a33dfcfeb5787d8d5ce84ca (patch)
treebcc43491e29afb1efaf3032ed2ba19658847a030 /dev-ml
parent0.21 beta build. add opengl USE flag (diff)
downloadgentoo-2-f3fc978595556b894a33dfcfeb5787d8d5ce84ca.tar.gz
gentoo-2-f3fc978595556b894a33dfcfeb5787d8d5ce84ca.tar.bz2
gentoo-2-f3fc978595556b894a33dfcfeb5787d8d5ce84ca.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camlp5/ChangeLog7
-rw-r--r--dev-ml/camlp5/camlp5-5.08.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-ml/camlp5/ChangeLog b/dev-ml/camlp5/ChangeLog
index 98d617f034c0..897e0afd4a18 100644
--- a/dev-ml/camlp5/ChangeLog
+++ b/dev-ml/camlp5/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/camlp5
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.15 2008/01/18 08:37:45 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.16 2008/02/23 23:36:55 aballier Exp $
+
+*camlp5-5.08 (23 Feb 2008)
+
+ 23 Feb 2008; Alexis Ballier <aballier@gentoo.org> +camlp5-5.08.ebuild:
+ version bump
18 Jan 2008; Alexis Ballier <aballier@gentoo.org> -camlp5-5.06.ebuild:
remove old
diff --git a/dev-ml/camlp5/camlp5-5.08.ebuild b/dev-ml/camlp5/camlp5-5.08.ebuild
new file mode 100644
index 000000000000..eb67cb6480d1
--- /dev/null
+++ b/dev-ml/camlp5/camlp5-5.08.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/camlp5-5.08.ebuild,v 1.1 2008/02/23 23:36:55 aballier Exp $
+
+inherit multilib findlib eutils
+
+EAPI="1"
+
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="http://pauillac.inria.fr/~ddr/camlp5/"
+SRC_URI="http://pauillac.inria.fr/~ddr/camlp5/distrib/src/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.09"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_compile() {
+ ./configure \
+ -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man || die "configure failed"
+
+ emake -j1 || die "emake failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "Compiling native code programs failed"
+ emake -j1 opt.opt || die "Compiling native code programs failed"
+ fi
+
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ # findlib support
+ insinto "$(ocamlfind printconf destdir)/${PN}"
+ doins etc/META || die "failed to install META file for findlib support"
+
+ use doc && dohtml -r doc/*
+
+ dodoc CHANGES DEVEL ICHANGES README UPGRADING MODE
+}