summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-06-21 12:14:24 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-06-21 12:14:24 +0000
commitf74c7a071289410b5b9191326fe7a486afcbaa49 (patch)
tree682367f21cfe2f1651c5e63a32702e3d26697418 /dev-ml
parentVersion bump (diff)
downloadgentoo-2-f74c7a071289410b5b9191326fe7a486afcbaa49.tar.gz
gentoo-2-f74c7a071289410b5b9191326fe7a486afcbaa49.tar.bz2
gentoo-2-f74c7a071289410b5b9191326fe7a486afcbaa49.zip
version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-sqlite3/ChangeLog8
-rw-r--r--dev-ml/ocaml-sqlite3/files/ocaml-sqlite3-1.5.1-werror.patch13
-rw-r--r--dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.5.1.ebuild46
3 files changed, 66 insertions, 1 deletions
diff --git a/dev-ml/ocaml-sqlite3/ChangeLog b/dev-ml/ocaml-sqlite3/ChangeLog
index 689e4d070b9d..6416e5f7f386 100644
--- a/dev-ml/ocaml-sqlite3/ChangeLog
+++ b/dev-ml/ocaml-sqlite3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/ocaml-sqlite3
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ChangeLog,v 1.11 2009/06/21 12:03:40 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ChangeLog,v 1.12 2009/06/21 12:14:24 aballier Exp $
+
+*ocaml-sqlite3-1.5.1 (21 Jun 2009)
+
+ 21 Jun 2009; Alexis Ballier <aballier@gentoo.org>
+ +ocaml-sqlite3-1.5.1.ebuild, +files/ocaml-sqlite3-1.5.1-werror.patch:
+ version bump
21 Jun 2009; Alexis Ballier <aballier@gentoo.org>
ocaml-sqlite3-1.2.0.ebuild:
diff --git a/dev-ml/ocaml-sqlite3/files/ocaml-sqlite3-1.5.1-werror.patch b/dev-ml/ocaml-sqlite3/files/ocaml-sqlite3-1.5.1-werror.patch
new file mode 100644
index 000000000000..ab0c709dedc9
--- /dev/null
+++ b/dev-ml/ocaml-sqlite3/files/ocaml-sqlite3-1.5.1-werror.patch
@@ -0,0 +1,13 @@
+Index: ocaml-sqlite3-1.5.1/Makefile.in
+===================================================================
+--- ocaml-sqlite3-1.5.1.orig/Makefile.in
++++ ocaml-sqlite3-1.5.1/Makefile.in
+@@ -12,7 +12,7 @@ else
+ endif
+
+ CC=@CC@
+-CFLAGS=@CPPFLAGS@ @CFLAGS@ $(HAS_ENABLE_LOAD_EXTENSION) -fPIC -Wall -pedantic -Werror -Wno-long-long
++CFLAGS=@CPPFLAGS@ @CFLAGS@ $(HAS_ENABLE_LOAD_EXTENSION) -fPIC -Wall -pedantic -Wno-long-long
+ LIBS=@LIBS@
+ LDFLAGS=@LDFLAGS@
+
diff --git a/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.5.1.ebuild b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.5.1.ebuild
new file mode 100644
index 000000000000..8b02e778e7ca
--- /dev/null
+++ b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.5.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.5.1.ebuild,v 1.1 2009/06/21 12:14:24 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+IUSE="doc +ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to SQLite databases."
+SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.gz"
+HOMEPAGE="http://ocaml.info/home/ocaml_sources.html#ocaml-sqlite3"
+
+DEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
+ >=dev-db/sqlite-3.3.3"
+
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.22.0-destdir.patch"
+ epatch "${FILESDIR}/${PN}-0.23.0-noocamlopt.patch"
+ epatch "${FILESDIR}/${PN}-1.5.1-werror.patch"
+}
+
+src_compile() {
+ emake -j1 bytecode || die "make bytecode failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "make opt failed"
+ fi
+ if use doc; then
+ emake -j1 docs || die "make doc failed"
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ export OCAMLPATH="${OCAMLFIND_DESTDIR}"
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc Changelog README.txt TODO
+ use doc && dohtml doc/*
+}