summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-08-30 15:03:49 +0000
committerTorsten Veller <tove@gentoo.org>2011-08-30 15:03:49 +0000
commitcfa1c989128ebc6c7ee85fba126b682024050550 (patch)
tree8016ccbe1cd2821e4de358bdd909cbc9d6cba281 /dev-perl/Goo-Canvas/Goo-Canvas-0.60.0.ebuild
parentChange version scheme (diff)
downloadgentoo-2-cfa1c989128ebc6c7ee85fba126b682024050550.tar.gz
gentoo-2-cfa1c989128ebc6c7ee85fba126b682024050550.tar.bz2
gentoo-2-cfa1c989128ebc6c7ee85fba126b682024050550.zip
Change version scheme
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/Goo-Canvas/Goo-Canvas-0.60.0.ebuild')
-rw-r--r--dev-perl/Goo-Canvas/Goo-Canvas-0.60.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Goo-Canvas/Goo-Canvas-0.60.0.ebuild b/dev-perl/Goo-Canvas/Goo-Canvas-0.60.0.ebuild
new file mode 100644
index 000000000000..ed5039cd2385
--- /dev/null
+++ b/dev-perl/Goo-Canvas/Goo-Canvas-0.60.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Goo-Canvas/Goo-Canvas-0.60.0.ebuild,v 1.1 2011/08/30 15:03:49 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=YEWENBIN
+MODULE_VERSION=0.06
+inherit perl-module
+
+DESCRIPTION="Perl interface to the GooCanvas"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/goocanvas:0
+ dev-perl/gtk2-perl
+ dev-perl/glib-perl
+ dev-perl/Cairo"
+DEPEND="${RDEPEND}
+ dev-perl/extutils-depends
+ dev-perl/extutils-pkgconfig"
+
+PATCHES=(
+ # this patch fixes segfaults on amd64 platforms
+ "${FILESDIR}"/fix_implicit_pointer_declaration.patch
+)