summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-04 12:54:31 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-04 12:54:31 +0000
commit0c536989e711628eda1ff1b0c18e862545f5f8a0 (patch)
treee11bc6b067dbf5c8d04ec9b0593ecd36d097c938 /dev-perl/PDL
parent*** empty log message *** (diff)
downloadgentoo-2-0c536989e711628eda1ff1b0c18e862545f5f8a0.tar.gz
gentoo-2-0c536989e711628eda1ff1b0c18e862545f5f8a0.tar.bz2
gentoo-2-0c536989e711628eda1ff1b0c18e862545f5f8a0.zip
Modified to work with the new perl package
Diffstat (limited to 'dev-perl/PDL')
-rw-r--r--dev-perl/PDL/PDL-2.1.1.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/dev-perl/PDL/PDL-2.1.1.ebuild b/dev-perl/PDL/PDL-2.1.1.ebuild
index 401263634e9d..752359ce0e99 100644
--- a/dev-perl/PDL/PDL-2.1.1.ebuild
+++ b/dev-perl/PDL/PDL-2.1.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.1.1.ebuild,v 1.4 2000/11/01 06:27:09 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.1.1.ebuild,v 1.5 2000/11/04 12:54:30 achim Exp $
P=PDL-2.1.1
A=${P}.tar.gz
@@ -11,7 +11,6 @@ SRC_URI="http://cpan.valueclick.com/modules/by-module/PDL/${A}"
HOMEPAGE="http://cpan.valueclick.com/modules/by-module/PDL/${P}.readme"
DEPEND=">=sys-devel/perl-5
- >=sys-libs/glibc-2.1.3
>=sys-libs/gpm-1.19.3
>=sys-libs/ncurses-5.1
>=dev-perl/ExtUtils-F77-1.13"
@@ -25,7 +24,7 @@ src_unpack() {
src_compile() {
cd ${S}
- perl Makefile.PL $PERLINSTALL
+ perl Makefile.PL
try make
try make test
@@ -34,9 +33,16 @@ src_compile() {
src_install () {
cd ${S}
- try make install
+ try make PREFIX=${D}/usr install
dodoc COPYING Changes DEPENDENCIES DEVELOPMENT README MANIFEST*
- dodoc Release_Notes TODO
+ dodoc Release_Notes TODO
+ mv ${D}/usr/lib/perl5/site_perl/5.6.0/i686-linux-thread-multi/PDL/HtmlDocs ${D}/usr/doc/${P}/html
+ mydir=${D}/usr/doc/${P}/html/PDL
+ for i in ${mydir}/* ${mydir}/IO/* ${mydir}/Fit/* ${mydir}/Pod/* ${mydir}/Graphics/*
+ do
+ dosed ${i/${D}}
+ done
+ dosed /usr/lib/perl5/site_perl/5.6.0/i686-linux-thread-multi/PDL/pdldoc.db
}