summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-09-05 11:02:19 +0000
committerTorsten Veller <tove@gentoo.org>2009-09-05 11:02:19 +0000
commit40154b36906f718312db4752ab9bb86c8a6bc41e (patch)
treece3f6d8c4346defac5d875212954b96828db6a4c /dev-perl/RPC-XML
parentInitial import of unpaper; ebuild from my overlay; closes bug #172958. (diff)
downloadgentoo-2-40154b36906f718312db4752ab9bb86c8a6bc41e.tar.gz
gentoo-2-40154b36906f718312db4752ab9bb86c8a6bc41e.tar.bz2
gentoo-2-40154b36906f718312db4752ab9bb86c8a6bc41e.zip
Version bump
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/RPC-XML')
-rw-r--r--dev-perl/RPC-XML/ChangeLog7
-rw-r--r--dev-perl/RPC-XML/RPC-XML-0.69.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-perl/RPC-XML/ChangeLog b/dev-perl/RPC-XML/ChangeLog
index 99977d5b0af4..3e1649210660 100644
--- a/dev-perl/RPC-XML/ChangeLog
+++ b/dev-perl/RPC-XML/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/RPC-XML
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/RPC-XML/ChangeLog,v 1.47 2009/07/16 09:17:33 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/RPC-XML/ChangeLog,v 1.48 2009/09/05 11:02:19 tove Exp $
+
+*RPC-XML-0.69 (05 Sep 2009)
+
+ 05 Sep 2009; Torsten Veller <tove@gentoo.org> +RPC-XML-0.69.ebuild:
+ Version bump
16 Jul 2009; Torsten Veller <tove@gentoo.org> -RPC-XML-0.64.ebuild,
-RPC-XML-0.65.ebuild:
diff --git a/dev-perl/RPC-XML/RPC-XML-0.69.ebuild b/dev-perl/RPC-XML/RPC-XML-0.69.ebuild
new file mode 100644
index 000000000000..51ddeb8d6c30
--- /dev/null
+++ b/dev-perl/RPC-XML/RPC-XML-0.69.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/RPC-XML/RPC-XML-0.69.ebuild,v 1.1 2009/09/05 11:02:19 tove Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=RJRAY
+inherit perl-module
+
+DESCRIPTION="An implementation of XML-RPC"
+
+SLOT="0"
+LICENSE="|| ( Artistic-2 LGPL-2.1 )"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+SRC_TEST="do"
+
+RDEPEND=">=dev-perl/libwww-perl-5.801
+ >=dev-perl/XML-LibXML-1.58
+ >=dev-perl/XML-Parser-2.31
+ dev-perl/net-server
+ >=virtual/perl-Scalar-List-Utils-1.20"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage )"
+
+pkg_postinst() {
+ perl-module_pkg_postinst
+
+ SETWARN=0
+ has_version '=www-servers/apache-2*' && HAVE_APACHE2=1
+ has_version '>=www-apache/mod_perl-2.0' && HAVE_MP2=2
+
+ [ -n "${HAVE_APACHE2}" ] && SETWARN=1
+ [ -n "${HAVE_MP2}" ] && SETWARN=1
+
+ if [ "$SETWARN" == "1" ]; then
+ ewarn "Apache2 or mod_perl2 were detected."
+ ewarn ""
+ ewarn "NOTE FROM THE AUTHOR OF RPC-XML"
+ ewarn ""
+ ewarn "At present, this package does not work with Apache2 and the soon-to-be"
+ ewarn "mod_perl2. The changes to the API for location handlers are too drastic to"
+ ewarn "try and support both within the same class (I tried, using the compatibility"
+ ewarn "layer). Also, mp2 does not currently provide support for <Perl> sections, which"
+ ewarn "are the real strength of the Apache::RPC::Server class."
+ fi
+}