summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-10-25 19:11:29 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-10-25 19:11:29 +0000
commitb58971d890709055d9d5adb7ba035e834814acc4 (patch)
tree6e18dda4bda577fc24aad73002db6b8c9e0e5e75 /dev-perl/RPC-XML
parentFix line endings (bug #526786). (diff)
downloadgentoo-2-b58971d890709055d9d5adb7ba035e834814acc4.tar.gz
gentoo-2-b58971d890709055d9d5adb7ba035e834814acc4.tar.bz2
gentoo-2-b58971d890709055d9d5adb7ba035e834814acc4.zip
Version bump, bug 523168
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'dev-perl/RPC-XML')
-rw-r--r--dev-perl/RPC-XML/ChangeLog8
-rw-r--r--dev-perl/RPC-XML/RPC-XML-0.780.0.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-perl/RPC-XML/ChangeLog b/dev-perl/RPC-XML/ChangeLog
index 592d55bfbb4e..db64f040444e 100644
--- a/dev-perl/RPC-XML/ChangeLog
+++ b/dev-perl/RPC-XML/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/RPC-XML
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/RPC-XML/ChangeLog,v 1.75 2014/08/24 02:42:34 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/RPC-XML/ChangeLog,v 1.76 2014/10/25 19:11:29 dilfridge Exp $
+
+*RPC-XML-0.780.0 (25 Oct 2014)
+
+ 25 Oct 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ +RPC-XML-0.780.0.ebuild:
+ Version bump, bug 523168
*RPC-XML-0.770.0-r1 (24 Aug 2014)
diff --git a/dev-perl/RPC-XML/RPC-XML-0.780.0.ebuild b/dev-perl/RPC-XML/RPC-XML-0.780.0.ebuild
new file mode 100644
index 000000000000..8313453cfdcd
--- /dev/null
+++ b/dev-perl/RPC-XML/RPC-XML-0.780.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/RPC-XML/RPC-XML-0.780.0.ebuild,v 1.1 2014/10/25 19:11:29 dilfridge Exp $
+
+EAPI=5
+
+MODULE_AUTHOR=RJRAY
+MODULE_VERSION=0.78
+inherit perl-module
+
+DESCRIPTION="An implementation of XML-RPC"
+
+SLOT="0"
+LICENSE="|| ( Artistic-2 LGPL-2.1 )"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="test"
+
+SRC_TEST="do"
+
+RDEPEND="
+ >=virtual/perl-File-Spec-0.800.0
+ >=dev-perl/libwww-perl-5.834.0
+ >=virtual/perl-Module-Load-0.240.0
+ >=virtual/perl-Scalar-List-Utils-1.200.0
+ >=dev-perl/XML-LibXML-1.850.0
+ >=dev-perl/XML-Parser-2.310.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.940.0 )
+"
+
+pkg_postinst() {
+ perl-module_pkg_postinst
+
+ SETWARN=0
+ has_version '=www-servers/apache-2*' && HAVE_APACHE2=1
+ has_version '>=www-apache/mod_perl-2.0' && HAVE_MP2=2
+
+ [ -n "${HAVE_APACHE2}" ] && SETWARN=1
+ [ -n "${HAVE_MP2}" ] && SETWARN=1
+
+ if [ "${SETWARN}" == "1" ]; then
+ ewarn "Apache2 or mod_perl2 were detected."
+ ewarn ""
+ ewarn "NOTE FROM THE AUTHOR OF RPC-XML"
+ ewarn ""
+ ewarn "At present, this package does not work with Apache2 and the soon-to-be"
+ ewarn "mod_perl2. The changes to the API for location handlers are too drastic to"
+ ewarn "try and support both within the same class (I tried, using the compatibility"
+ ewarn "layer). Also, mp2 does not currently provide support for <Perl> sections, which"
+ ewarn "are the real strength of the Apache::RPC::Server class."
+ fi
+}