summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-08-24 12:58:25 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-08-24 12:58:25 +0000
commit6e2da64ca4e5698906515490f99040e0178ea1e1 (patch)
tree1abc91d3aa867ae52d547448add1e5b81e269f67 /dev-perl/SDL/SDL-2.540-r1.ebuild
parentbumped EAPI to 5; committed directly to stable as no other changes present an... (diff)
downloadgentoo-2-6e2da64ca4e5698906515490f99040e0178ea1e1.tar.gz
gentoo-2-6e2da64ca4e5698906515490f99040e0178ea1e1.tar.bz2
gentoo-2-6e2da64ca4e5698906515490f99040e0178ea1e1.zip
bumped current stable ebuild(s) EAPI to 5; committed directly to stable as no other changes present and revbump helps stable systems to keep from dieing on perl-5.18 upgrade
(Portage version: 2.2.8-r1/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'dev-perl/SDL/SDL-2.540-r1.ebuild')
-rw-r--r--dev-perl/SDL/SDL-2.540-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/SDL/SDL-2.540-r1.ebuild b/dev-perl/SDL/SDL-2.540-r1.ebuild
new file mode 100644
index 000000000000..f376c6a00e77
--- /dev/null
+++ b/dev-perl/SDL/SDL-2.540-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SDL/SDL-2.540-r1.ebuild,v 1.1 2014/08/24 12:58:25 axs Exp $
+
+EAPI=5
+MODULE_AUTHOR=JTPALMER
+inherit perl-module
+
+DESCRIPTION="Simple DirectMedia Layer (SDL) bindings for perl"
+HOMEPAGE="http://sdl.perl.org/ http://search.cpan.org/dist/SDL/ http://github.com/PerlGameDev/SDL"
+
+LICENSE="GPL-2 OFL-1.1"
+SLOT="0"
+KEYWORDS="amd64 hppa x86"
+IUSE=""
+
+RDEPEND=">=dev-perl/Alien-SDL-1.434
+ dev-perl/Capture-Tiny
+ dev-perl/File-ShareDir
+ dev-perl/Test-Most
+ dev-perl/Tie-Simple
+ media-libs/libpng:0
+ media-libs/libsdl
+ media-libs/sdl-gfx
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-pango
+ media-libs/sdl-ttf
+ media-libs/smpeg
+ media-libs/tiff:0
+ virtual/glu
+ virtual/jpeg
+ virtual/opengl
+ virtual/perl-ExtUtils-CBuilder
+ >=virtual/perl-Module-Build-0.400.0
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Test-Simple"
+DEPEND=${RDEPEND}
+
+SRC_TEST=do
+mydoc='CHANGELOG README TODO'