summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-09-11 01:23:33 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-09-11 01:23:33 +0000
commitc1a649b3759a97c50a1448be3e500a8ddcbbfa68 (patch)
treef5df5496937cade635460c859e72bc114aa3f169 /dev-perl/SOAP-Lite
parentrevert change to libexec for bug #381783. (diff)
downloadgentoo-2-c1a649b3759a97c50a1448be3e500a8ddcbbfa68.tar.gz
gentoo-2-c1a649b3759a97c50a1448be3e500a8ddcbbfa68.tar.bz2
gentoo-2-c1a649b3759a97c50a1448be3e500a8ddcbbfa68.zip
Version bump via perl-bump experimental tool.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/SOAP-Lite')
-rw-r--r--dev-perl/SOAP-Lite/ChangeLog7
-rw-r--r--dev-perl/SOAP-Lite/SOAP-Lite-0.714.0.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-perl/SOAP-Lite/ChangeLog b/dev-perl/SOAP-Lite/ChangeLog
index 7452223826a9..92a904ac25a3 100644
--- a/dev-perl/SOAP-Lite/ChangeLog
+++ b/dev-perl/SOAP-Lite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/SOAP-Lite
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/ChangeLog,v 1.69 2011/09/07 16:24:31 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/ChangeLog,v 1.70 2011/09/11 01:23:33 robbat2 Exp $
+
+*SOAP-Lite-0.714.0 (11 Sep 2011)
+
+ 11 Sep 2011; Robin H. Johnson <robbat2@gentoo.org> +SOAP-Lite-0.714.0.ebuild:
+ Version bump via perl-bump experimental tool.
07 Sep 2011; Justin Lecher <jlec@gentoo.org> SOAP-Lite-0.712.0.ebuild,
metadata.xml:
diff --git a/dev-perl/SOAP-Lite/SOAP-Lite-0.714.0.ebuild b/dev-perl/SOAP-Lite/SOAP-Lite-0.714.0.ebuild
new file mode 100644
index 000000000000..e6f1f7a891ac
--- /dev/null
+++ b/dev-perl/SOAP-Lite/SOAP-Lite-0.714.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/SOAP-Lite-0.714.0.ebuild,v 1.1 2011/09/11 01:23:33 robbat2 Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=MKUTTER
+MODULE_VERSION=0.714
+inherit perl-module eutils
+
+DESCRIPTION="Simple and lightweight interface to the SOAP protocol (sic) both on client and server side"
+
+IUSE="jabber ssl"
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+myconf="${myconf} --noprompt"
+
+# TESTS ARE DISABLED ON PURPOSE
+# This module attempts to access an external website for validation
+# of the MIME::Parser - not only is that bad practice in general,
+# but in this particular case the external site isn't even valid anymore# -mpc
+# 24/10/04
+SRC_TEST="do"
+
+DEPEND="dev-perl/Class-Inspector
+ dev-perl/XML-Parser
+ dev-perl/libwww-perl
+ virtual/perl-libnet
+ dev-perl/MIME-Lite
+ virtual/perl-MIME-Base64
+ ssl? ( dev-perl/Crypt-SSLeay )
+ jabber? ( dev-perl/Net-Jabber )
+ ssl? ( dev-perl/IO-Socket-SSL )
+ virtual/perl-IO-Compress
+ >=dev-perl/MIME-tools-5.413
+ virtual/perl-version
+ dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # The author of this module put a dep for MIME::Parser 6.X - but the6.X
+ # release of MIME::Parser was a mistake during a change in maintainers on
+ # cpan. This patch alters the dependancy to the "real" stable version of
+ # MIME::Parser.
+ epatch "${FILESDIR}"/SOAP-Lite-0.710.08.patch
+ # Merged upstream
+ #epatch "${FILESDIR}"/${PN}-0.712_sysread.patch
+}
+
+src_test() {
+ has_version '>=www-apache/mod_perl-2' && export MOD_PERL_API_VERSION=2
+ perl-module_src_test
+}