summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hartmann <ian@gentoo.org>2006-07-07 19:12:28 +0000
committerChristian Hartmann <ian@gentoo.org>2006-07-07 19:12:28 +0000
commit75a89104e9ccb0ea01ddebb03ef4683c6b7147f0 (patch)
treefd0ab21ddfb12205ca64ea7426e0eb888b757a07 /dev-perl/Test-WWW-Mechanize/Test-WWW-Mechanize-1.12.ebuild
parentSmall fixes for strip-linguas and start problems (diff)
downloadgentoo-2-75a89104e9ccb0ea01ddebb03ef4683c6b7147f0.tar.gz
gentoo-2-75a89104e9ccb0ea01ddebb03ef4683c6b7147f0.tar.bz2
gentoo-2-75a89104e9ccb0ea01ddebb03ef4683c6b7147f0.zip
Version bump
(Portage version: 2.1.1_pre2-r4)
Diffstat (limited to 'dev-perl/Test-WWW-Mechanize/Test-WWW-Mechanize-1.12.ebuild')
-rw-r--r--dev-perl/Test-WWW-Mechanize/Test-WWW-Mechanize-1.12.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-perl/Test-WWW-Mechanize/Test-WWW-Mechanize-1.12.ebuild b/dev-perl/Test-WWW-Mechanize/Test-WWW-Mechanize-1.12.ebuild
new file mode 100644
index 000000000000..de4becc77de0
--- /dev/null
+++ b/dev-perl/Test-WWW-Mechanize/Test-WWW-Mechanize-1.12.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Test-WWW-Mechanize/Test-WWW-Mechanize-1.12.ebuild,v 1.1 2006/07/07 19:12:28 ian Exp $
+
+inherit perl-module
+
+DESCRIPTION="Test::WWW::Mechanize is a subclass of WWW::Mechanize that
+incorporates features for web application testing"
+SRC_URI="mirror://cpan/authors/id/P/PE/PETDANCE/${P}.tar.gz"
+HOMEPAGE="http://search.cpan.org/~petdance/${P}/"
+IUSE=""
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+SRC_TEST="do"
+
+DEPEND=">=dev-perl/WWW-Mechanize-1.00
+ dev-perl/Carp-Assert-More
+ >=dev-perl/HTTP-Server-Simple-0.07
+ dev-perl/URI
+ >=dev-perl/Test-LongString-0.07"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ echo "y" | perl-module_src_compile
+}