summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-01-13 20:23:19 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-01-13 20:23:19 +0000
commit1dd73dca3c3ac2f24cf24898a5d18eac17e6a7ea (patch)
tree11b498dc608ba0578fdeaaa796edda482065998b /dev-perl/WWW-Mechanize
parentVersion bump via perl-bump experimental tool. (diff)
downloadgentoo-2-1dd73dca3c3ac2f24cf24898a5d18eac17e6a7ea.tar.gz
gentoo-2-1dd73dca3c3ac2f24cf24898a5d18eac17e6a7ea.tar.bz2
gentoo-2-1dd73dca3c3ac2f24cf24898a5d18eac17e6a7ea.zip
Version bump via perl-bump experimental tool.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28-05718-g0556e82 x86_64)
Diffstat (limited to 'dev-perl/WWW-Mechanize')
-rw-r--r--dev-perl/WWW-Mechanize/ChangeLog10
-rw-r--r--dev-perl/WWW-Mechanize/WWW-Mechanize-1.54.ebuild41
2 files changed, 49 insertions, 2 deletions
diff --git a/dev-perl/WWW-Mechanize/ChangeLog b/dev-perl/WWW-Mechanize/ChangeLog
index 8a02fd97cbff..ad358fa6adfa 100644
--- a/dev-perl/WWW-Mechanize/ChangeLog
+++ b/dev-perl/WWW-Mechanize/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/WWW-Mechanize
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/ChangeLog,v 1.55 2008/12/17 09:21:21 tove Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/ChangeLog,v 1.56 2009/01/13 20:23:19 robbat2 Exp $
+
+*WWW-Mechanize-1.54 (13 Jan 2009)
+
+ 13 Jan 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +WWW-Mechanize-1.54.ebuild:
+ Version bump via perl-bump experimental tool.
17 Dec 2008; Torsten Veller <tove@gentoo.org> WWW-Mechanize-1.52.ebuild:
Adjust DEPEND, remove test and fix #251212.
diff --git a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.54.ebuild b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.54.ebuild
new file mode 100644
index 000000000000..607c456b2665
--- /dev/null
+++ b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.54.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/WWW-Mechanize-1.54.ebuild,v 1.1 2009/01/13 20:23:19 robbat2 Exp $
+
+MODULE_AUTHOR=PETDANCE
+inherit perl-module
+
+DESCRIPTION="Handy web browsing in a Perl object"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+# Bug in the tests - improper use of HTTP::Server
+SRC_TEST="do"
+
+# configure to run the local tests, but not the ones which access the Internet
+myconf="--local --nolive"
+
+RDEPEND="dev-lang/perl
+ dev-perl/IO-Socket-SSL
+ >=dev-perl/libwww-perl-5.819
+ dev-perl/HTTP-Response-Encoding
+ >=dev-perl/URI-1.36
+ >=dev-perl/HTML-Parser-3.34
+ dev-perl/Test-LongString"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Test-Pod
+ dev-perl/Test-Taint
+ >=dev-perl/Test-Warn-0.11
+ dev-perl/Test-Memory-Cycle )"
+# dev-perl/HTTP-Server-Simple )"
+
+# Remove test until the bug is fixed:
+# http://rt.cpan.org/Public/Bug/Display.html?id=41673
+src_unpack() {
+ perl-module_src_unpack
+ mv "${S}"/t/cookies.t{,.disable} || die
+ sed -i "/cookies.t/d" "${S}/MANIFEST" || die
+}