summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-01-21 19:33:19 +0000
committerTorsten Veller <tove@gentoo.org>2010-01-21 19:33:19 +0000
commitd03acb23cefa64d22420727870bcc160aa2aa0b2 (patch)
tree02460e348cfee67a73e27e98037972d75af10317 /dev-perl/WWW-Shorten
parentFix typo on src_prepare function (diff)
downloadgentoo-2-d03acb23cefa64d22420727870bcc160aa2aa0b2.tar.gz
gentoo-2-d03acb23cefa64d22420727870bcc160aa2aa0b2.tar.bz2
gentoo-2-d03acb23cefa64d22420727870bcc160aa2aa0b2.zip
Version bump
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/WWW-Shorten')
-rw-r--r--dev-perl/WWW-Shorten/ChangeLog9
-rw-r--r--dev-perl/WWW-Shorten/WWW-Shorten-3.00.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/dev-perl/WWW-Shorten/ChangeLog b/dev-perl/WWW-Shorten/ChangeLog
index bbfe812378c9..3e12ec8d60c7 100644
--- a/dev-perl/WWW-Shorten/ChangeLog
+++ b/dev-perl/WWW-Shorten/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/WWW-Shorten
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Shorten/ChangeLog,v 1.3 2009/12/05 14:58:54 tove Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Shorten/ChangeLog,v 1.4 2010/01/21 19:33:19 tove Exp $
+
+*WWW-Shorten-3.00 (21 Jan 2010)
+
+ 21 Jan 2010; Torsten Veller <tove@gentoo.org> +WWW-Shorten-3.00.ebuild:
+ Version bump
05 Dec 2009; Torsten Veller <tove@gentoo.org> -WWW-Shorten-2.05.ebuild,
WWW-Shorten-2.06.ebuild:
diff --git a/dev-perl/WWW-Shorten/WWW-Shorten-3.00.ebuild b/dev-perl/WWW-Shorten/WWW-Shorten-3.00.ebuild
new file mode 100644
index 000000000000..a7479bb9e7af
--- /dev/null
+++ b/dev-perl/WWW-Shorten/WWW-Shorten-3.00.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Shorten/WWW-Shorten-3.00.ebuild,v 1.1 2010/01/21 19:33:19 tove Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=DAVECROSS
+inherit perl-module
+
+DESCRIPTION="Interface to URL shortening sites"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-perl/libwww-perl
+ dev-perl/URI"
+DEPEND="virtual/perl-Module-Build"
+# test? ( ${RDEPEND}
+# dev-perl/Test-Pod
+# dev-perl/Test-Pod-Coverage )"
+
+# online tests
+SRC_TEST=skip
+
+src_install() {
+ perl-module_src_install
+
+ docinto example
+ dodoc "${S}"/bin/shorten || die
+ rm -f "${D}"/usr/bin/shorten "${D}"/usr/share/man/man1/shorten.1 || die
+}