summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2013-07-27 17:53:26 +0000
committerMikle Kolyada <zlogene@gentoo.org>2013-07-27 17:53:26 +0000
commit1ec3385ae2e6177ee31c597decee0b79cd3bd164 (patch)
tree23a0dc53267742785a0061aad7e7d62d912574a6 /dev-perl/math-pari
parentMake cups mandatory, bug 478364 (diff)
downloadgentoo-2-1ec3385ae2e6177ee31c597decee0b79cd3bd164.tar.gz
gentoo-2-1ec3385ae2e6177ee31c597decee0b79cd3bd164.tar.bz2
gentoo-2-1ec3385ae2e6177ee31c597decee0b79cd3bd164.zip
Respect AR
(Portage version: 2.1.12.2/cvs/Linux i686, signed Manifest commit with key 0xC42EB5D6)
Diffstat (limited to 'dev-perl/math-pari')
-rw-r--r--dev-perl/math-pari/ChangeLog8
-rw-r--r--dev-perl/math-pari/math-pari-2.01080604.ebuild10
-rw-r--r--dev-perl/math-pari/math-pari-2.10.806.50.ebuild10
3 files changed, 20 insertions, 8 deletions
diff --git a/dev-perl/math-pari/ChangeLog b/dev-perl/math-pari/ChangeLog
index f38da06f85d5..d17ea88b3058 100644
--- a/dev-perl/math-pari/ChangeLog
+++ b/dev-perl/math-pari/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-perl/math-pari
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.70 2012/06/24 13:00:22 tove Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.71 2013/07/27 17:53:26 zlogene Exp $
+
+ 27 Jul 2013; Mikle Kolyada <zlogene@gentoo.org> math-pari-2.01080604.ebuild,
+ math-pari-2.10.806.50.ebuild:
+ Respect AR
24 Jun 2012; Torsten Veller <tove@gentoo.org> metadata.xml:
Update CPAN upstream info
diff --git a/dev-perl/math-pari/math-pari-2.01080604.ebuild b/dev-perl/math-pari/math-pari-2.01080604.ebuild
index f846c27bc9a9..7f0bd9c8f7e7 100644
--- a/dev-perl/math-pari/math-pari-2.01080604.ebuild
+++ b/dev-perl/math-pari/math-pari-2.01080604.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/math-pari-2.01080604.ebuild,v 1.5 2010/06/26 17:10:47 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/math-pari-2.01080604.ebuild,v 1.6 2013/07/27 17:53:26 zlogene Exp $
EAPI=2
@@ -8,7 +8,7 @@ MODULE_AUTHOR=ILYAZ
MODULE_SECTION=modules
MY_PN=Math-Pari
MY_P=${MY_PN}-${PV}
-inherit perl-module
+inherit perl-module toolchain-funcs
PARI_VER=2.3.4
@@ -58,3 +58,7 @@ src_configure() {
perl-module_src_configure
}
+
+src_compile() {
+ emake AR="$(tc-getAR)" OTHERLDFLAGS="${LDFLAGS}"
+}
diff --git a/dev-perl/math-pari/math-pari-2.10.806.50.ebuild b/dev-perl/math-pari/math-pari-2.10.806.50.ebuild
index 3cd716554cf2..4d9d83017597 100644
--- a/dev-perl/math-pari/math-pari-2.10.806.50.ebuild
+++ b/dev-perl/math-pari/math-pari-2.10.806.50.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/math-pari-2.10.806.50.ebuild,v 1.1 2011/04/30 07:31:07 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/math-pari-2.10.806.50.ebuild,v 1.2 2013/07/27 17:53:26 zlogene Exp $
EAPI=4
@@ -8,7 +8,7 @@ MODULE_AUTHOR=ILYAZ
MODULE_SECTION=modules
MODULE_VERSION=2.01080605
MY_PN=Math-Pari
-inherit perl-module
+inherit perl-module toolchain-funcs
PARI_VER=2.3.5
@@ -57,3 +57,7 @@ src_configure() {
perl-module_src_configure
}
+
+src_compile() {
+ emake AR="$(tc-getAR)" OTHERLDFLAGS="${LDFLAGS}"
+}