summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2006-11-07 13:12:25 +0000
committerMichael Cummings <mcummings@gentoo.org>2006-11-07 13:12:25 +0000
commit4fa78d62ef46bf7a2e729664a378346ce2b23841 (patch)
treedb1414e089a03a112ab8f3dcd4b938e7c37ce501 /dev-perl/math-pari
parentAdded ~ppc, bug #154341 (diff)
downloadgentoo-2-4fa78d62ef46bf7a2e729664a378346ce2b23841.tar.gz
gentoo-2-4fa78d62ef46bf7a2e729664a378346ce2b23841.tar.bz2
gentoo-2-4fa78d62ef46bf7a2e729664a378346ce2b23841.zip
Version bump
(Portage version: 2.1.2_rc1-r3)
Diffstat (limited to 'dev-perl/math-pari')
-rw-r--r--dev-perl/math-pari/ChangeLog8
-rw-r--r--dev-perl/math-pari/files/digest-math-pari-2.0107096
-rw-r--r--dev-perl/math-pari/math-pari-2.010709.ebuild37
3 files changed, 50 insertions, 1 deletions
diff --git a/dev-perl/math-pari/ChangeLog b/dev-perl/math-pari/ChangeLog
index 74a69b0155da..d0aad09cabab 100644
--- a/dev-perl/math-pari/ChangeLog
+++ b/dev-perl/math-pari/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/math-pari
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.34 2006/10/23 19:38:03 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.35 2006/11/07 13:12:25 mcummings Exp $
+
+*math-pari-2.010709 (07 Nov 2006)
+
+ 07 Nov 2006; Michael Cummings <mcummings@gentoo.org>
+ +math-pari-2.010709.ebuild:
+ Version bump
23 Oct 2006; Gustavo Zacarias <gustavoz@gentoo.org>
math-pari-2.010706.ebuild:
diff --git a/dev-perl/math-pari/files/digest-math-pari-2.010709 b/dev-perl/math-pari/files/digest-math-pari-2.010709
new file mode 100644
index 000000000000..1cf78c4d2475
--- /dev/null
+++ b/dev-perl/math-pari/files/digest-math-pari-2.010709
@@ -0,0 +1,6 @@
+MD5 58fdea358b37d00072723bd9cd69ce9e Math-Pari-2.010709.tar.gz 113280
+RMD160 d857076dec295a2e3b2c6b7dd98055d31c443bf6 Math-Pari-2.010709.tar.gz 113280
+SHA256 f64c4d7540b1f67ae3c3b69e0dbb0aaa898c70e1f5519106acf8d63243dbcb9b Math-Pari-2.010709.tar.gz 113280
+MD5 357b7a42e89e2761a5367bbcbfcca5f2 pari-2.1.7.tgz 1542137
+RMD160 6d7ca649cdd457d96c12e1f9333143d496a78b7e pari-2.1.7.tgz 1542137
+SHA256 9142f2cdaf3083c8962f1a5c2bb0e9fe8915f7d9490c03312ac2361c7ea155fa pari-2.1.7.tgz 1542137
diff --git a/dev-perl/math-pari/math-pari-2.010709.ebuild b/dev-perl/math-pari/math-pari-2.010709.ebuild
new file mode 100644
index 000000000000..d04ca0a684b3
--- /dev/null
+++ b/dev-perl/math-pari/math-pari-2.010709.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/math-pari-2.010709.ebuild,v 1.1 2006/11/07 13:12:25 mcummings Exp $
+
+inherit perl-module eutils
+
+MY_P="Math-Pari-${PV}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Perl interface to PARI"
+HOMEPAGE="http://www.cpan.org/authors/id/I/IL/ILYAZ/modules/${MY_P}.readme"
+SRC_URI="mirror://cpan/authors/id/I/IL/ILYAZ/modules/${MY_P}.tar.gz
+ http://pari.math.u-bordeaux.fr/pub/pari/unix/pari-2.1.7.tgz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+SRC_TEST="do"
+
+# Math::Pari requires that a copy of the pari source in a parallel
+# directory to where you build it. It does not need to compile it, but
+# it does need to be the same version as is installed, hence the hard
+# DEPEND below
+DEPEND="~sci-mathematics/pari-2.1.7
+ dev-lang/perl"
+
+src_compile() {
+ # Unfortunately the assembly routines math-pari has for SPARC do not appear
+ # to be working at current. Perl cannot test math-pari or anything that
+ # pulls in the math-pari module as DynaLoader cannot load the resulting
+ # .so files math-pari generates. As such, we have to use the generic
+ # non-machine specific assembly methods here.
+ use sparc && myconf="${myconf} machine=none"
+
+ perl-module_src_compile
+}