summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2006-02-20 13:19:30 +0000
committerMichael Cummings <mcummings@gentoo.org>2006-02-20 13:19:30 +0000
commit7c0589b26b29541a8c6d9c6bce33d1af1f18e674 (patch)
tree70580372fd42b174d3b13b1aae6dab177cc53153 /dev-perl/yaml/yaml-0.58.ebuild
parentBad me, commiting a non-existing baselayout-version. Newest rc-scripts versio... (diff)
downloadgentoo-2-7c0589b26b29541a8c6d9c6bce33d1af1f18e674.tar.gz
gentoo-2-7c0589b26b29541a8c6d9c6bce33d1af1f18e674.tar.bz2
gentoo-2-7c0589b26b29541a8c6d9c6bce33d1af1f18e674.zip
bump fix; uses test keyword now
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'dev-perl/yaml/yaml-0.58.ebuild')
-rw-r--r--dev-perl/yaml/yaml-0.58.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/yaml/yaml-0.58.ebuild b/dev-perl/yaml/yaml-0.58.ebuild
new file mode 100644
index 000000000000..246cbe275418
--- /dev/null
+++ b/dev-perl/yaml/yaml-0.58.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/yaml/yaml-0.58.ebuild,v 1.1 2006/02/20 13:19:30 mcummings Exp $
+
+inherit perl-module
+
+MY_P="YAML-${PV}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="YAML Ain't Markup Language (tm)"
+HOMEPAGE="http://search.cpan.org/search?query=${PN}"
+SRC_URI="mirror://cpan/authors/id/I/IN/INGY/${MY_P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+DEPEND="test? ( >=dev-perl/Test-Base-0.49 ) "
+
+SRC_TEST="do"
+
+src_compile() {
+ echo "" | perl-module_src_compile
+}