summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-05-12 16:08:31 +0000
committerTorsten Veller <tove@gentoo.org>2011-05-12 16:08:31 +0000
commit11345cb8d831c6a7d1e2587182130fd80acb59ed (patch)
tree5c381f885e9c72525694759fbb58bc6eb6213e8e /dev-perl
parent[bump] dev-perl/PatchReader-0.9.6 (diff)
downloadgentoo-2-11345cb8d831c6a7d1e2587182130fd80acb59ed.tar.gz
gentoo-2-11345cb8d831c6a7d1e2587182130fd80acb59ed.tar.bz2
gentoo-2-11345cb8d831c6a7d1e2587182130fd80acb59ed.zip
[bump] dev-perl/DBD-Pg-2.18.1
(Portage version: 2.2.0_alpha32/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/DBD-Pg/ChangeLog7
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-2.18.1.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-perl/DBD-Pg/ChangeLog b/dev-perl/DBD-Pg/ChangeLog
index 6b777becbc06..ba9c0eb05599 100644
--- a/dev-perl/DBD-Pg/ChangeLog
+++ b/dev-perl/DBD-Pg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/DBD-Pg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/ChangeLog,v 1.93 2011/04/16 18:00:39 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/ChangeLog,v 1.94 2011/05/12 16:08:31 tove Exp $
+
+*DBD-Pg-2.18.1 (12 May 2011)
+
+ 12 May 2011; Torsten Veller <tove@gentoo.org> +DBD-Pg-2.18.1.ebuild:
+ Version bump
16 Apr 2011; Raúl Porcel <armin76@gentoo.org> DBD-Pg-2.17.2.ebuild:
alpha/ia64/s390/sh/sparc/x86 stable wrt #360245
diff --git a/dev-perl/DBD-Pg/DBD-Pg-2.18.1.ebuild b/dev-perl/DBD-Pg/DBD-Pg-2.18.1.ebuild
new file mode 100644
index 000000000000..40ce5f55cf7a
--- /dev/null
+++ b/dev-perl/DBD-Pg/DBD-Pg-2.18.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/DBD-Pg-2.18.1.ebuild,v 1.1 2011/05/12 16:08:31 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=TURNSTEP
+MODULE_VERSION=2.18.1
+inherit perl-module
+
+DESCRIPTION="The Perl DBD::Pg Module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="virtual/perl-version
+ >=dev-perl/DBI-1.52
+ dev-db/postgresql-base"
+DEPEND="${RDEPEND}"
+
+# testcases require a local database with an
+# open password for the postgres user.
+SRC_TEST="skip"
+
+src_prepare() {
+ postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
+ postgres_lib="${postgres_include//include/lib}"
+ # Fall-through case is the non-split postgresql
+ # The active cases instead get us the matching libdir for the includedir.
+ for i in lib lib64 ; do
+ if [ -d "${postgres_lib}/${i}" ]; then
+ postgres_lib="${postgres_lib}/${i}"
+ break
+ fi
+ done
+
+ # env variables for compilation:
+ export POSTGRES_INCLUDE="${postgres_include}"
+ export POSTGRES_LIB="${postgres_lib}"
+ perl-module_src_prepare
+}