summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-03-28 00:48:51 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-03-28 00:48:51 +0000
commit4e0cb19ea9f4e4bb0cdae1fb90878c015d3235ac (patch)
treeb6cfb1267689d163ceeec2f12c0a136f96cf1811 /dev-perl
parentFix header. (diff)
downloadgentoo-2-4e0cb19ea9f4e4bb0cdae1fb90878c015d3235ac.tar.gz
gentoo-2-4e0cb19ea9f4e4bb0cdae1fb90878c015d3235ac.tar.bz2
gentoo-2-4e0cb19ea9f4e4bb0cdae1fb90878c015d3235ac.zip
Version bump via perl-bump experimental tool.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/HTML-Mason/ChangeLog10
-rw-r--r--dev-perl/HTML-Mason/HTML-Mason-1.44.ebuild60
2 files changed, 68 insertions, 2 deletions
diff --git a/dev-perl/HTML-Mason/ChangeLog b/dev-perl/HTML-Mason/ChangeLog
index c5331d83e9ef..7f4581b7fb1a 100644
--- a/dev-perl/HTML-Mason/ChangeLog
+++ b/dev-perl/HTML-Mason/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/HTML-Mason
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/ChangeLog,v 1.93 2009/12/24 20:03:43 tove Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/ChangeLog,v 1.94 2010/03/28 00:48:51 robbat2 Exp $
+
+*HTML-Mason-1.44 (28 Mar 2010)
+
+ 28 Mar 2010; Robin H. Johnson <robbat2@gentoo.org>
+ +HTML-Mason-1.44.ebuild:
+ Version bump via perl-bump experimental tool.
24 Dec 2009; Torsten Veller <tove@gentoo.org> -HTML-Mason-1.37.ebuild:
Cleanup
diff --git a/dev-perl/HTML-Mason/HTML-Mason-1.44.ebuild b/dev-perl/HTML-Mason/HTML-Mason-1.44.ebuild
new file mode 100644
index 000000000000..22bd73ae60b2
--- /dev/null
+++ b/dev-perl/HTML-Mason/HTML-Mason-1.44.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/HTML-Mason-1.44.ebuild,v 1.1 2010/03/28 00:48:51 robbat2 Exp $
+
+inherit depend.apache perl-module
+
+DESCRIPTION="A HTML development and delivery Perl Module"
+SRC_URI="mirror://cpan/authors/id/D/DR/DROLSKY/${P}.tar.gz"
+HOMEPAGE="http://www.masonhq.com/"
+
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="modperl doc test"
+SRC_TEST="do"
+
+RDEPEND="!modperl? ( virtual/perl-CGI )
+ modperl? (
+ www-apache/libapreq2
+ >=www-apache/mod_perl-2
+ )
+ >=dev-perl/Params-Validate-0.7
+ >=dev-perl/Class-Container-0.08
+ >=dev-perl/Exception-Class-1.15
+ dev-perl/HTML-Parser
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-File-Spec
+ >=dev-perl/Cache-Cache-1.01
+ dev-perl/Log-Any"
+
+DEPEND="${RDEPEND}
+ virtual/perl-Module-Build
+ test? ( dev-perl/Test-Deep )"
+
+want_apache2 modperl
+
+mydoc="CREDITS UPGRADE"
+myconf="--noprompts"
+
+pkg_setup() {
+ depend.apache_pkg_setup modperl
+ perl-module_pkg_setup
+}
+
+perl-module_src_prep() {
+ # Note about new modperl use flag
+ if use !modperl ; then
+ ewarn "HTML-Mason will only install with modperl support"
+ ewarn "if the use flag modperl is enabled."
+ sleep 5
+ fi
+ # rendhalver - needed to set an env var for the build script so it finds our apache.
+ APACHE="${APACHE_BIN}" perl ${S}/Build.PL installdirs=vendor destdir=${D} ${myconf}
+}
+
+src_install () {
+ perl-module_src_install
+ # rendhalver - the html docs have subdirs so this gets all of them
+ use doc && dohtml -r htdocs/*
+}