summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-12-09 20:59:11 +0000
committerDonny Davies <woodchip@gentoo.org>2001-12-09 20:59:11 +0000
commitc329e62525012b812ff5df8b05f8689008cc2299 (patch)
treecdf212b634c2895e338cab958a8e1a9abdd81d4a /dev-perl
parentfix java symlink removed every second merge (diff)
downloadgentoo-2-c329e62525012b812ff5df8b05f8689008cc2299.tar.gz
gentoo-2-c329e62525012b812ff5df8b05f8689008cc2299.tar.bz2
gentoo-2-c329e62525012b812ff5df8b05f8689008cc2299.zip
The Perl CGI Module.
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/CGI/CGI-2.78.ebuild28
-rw-r--r--dev-perl/CGI/files/digest-CGI-2.781
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/CGI/CGI-2.78.ebuild b/dev-perl/CGI/CGI-2.78.ebuild
new file mode 100644
index 000000000000..703e73047dc1
--- /dev/null
+++ b/dev-perl/CGI/CGI-2.78.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/CGI/CGI-2.78.ebuild,v 1.1 2001/12/09 20:59:11 woodchip Exp $
+
+S=${WORKDIR}/${PN}.pm-${PV}
+DESCRIPTION="The Perl CGI Module"
+SRC_URI="http://www.cpan.org/authors/id/LDS/${PN}.pm-${PV}.tar.gz"
+HOMEPAGE="http://www-genome.wi.mit.edu/~lstein/"
+
+DEPEND="virtual/glibc >=sys-devel/perl-5"
+
+src_compile() {
+
+ perl Makefile.PL
+ make || die "possibly missing a DEPEND?"
+}
+
+src_install() {
+
+ make \
+ PREFIX=${D}/usr \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ INSTALLMAN1DIR=${D}/usr/share/man/man1 \
+ install || die
+
+ dodoc ANNOUNCE Changes MANIFEST README
+}
diff --git a/dev-perl/CGI/files/digest-CGI-2.78 b/dev-perl/CGI/files/digest-CGI-2.78
new file mode 100644
index 000000000000..6744cb39e531
--- /dev/null
+++ b/dev-perl/CGI/files/digest-CGI-2.78
@@ -0,0 +1 @@
+MD5 da09987ebc118123f54331685f22e203 CGI.pm-2.78.tar.gz 196608