summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2012-02-14 15:05:54 +0000
committerTorsten Veller <tove@gentoo.org>2012-02-14 15:05:54 +0000
commitcdea13093af2b373af5578c9ce8fd00ad4ba8914 (patch)
tree6539a1b41111e3fffa76868f24aa3439d598ca62 /dev-perl
parentBump to release version. (diff)
downloadgentoo-2-cdea13093af2b373af5578c9ce8fd00ad4ba8914.tar.gz
gentoo-2-cdea13093af2b373af5578c9ce8fd00ad4ba8914.tar.bz2
gentoo-2-cdea13093af2b373af5578c9ce8fd00ad4ba8914.zip
[bump] dev-perl/JSON-RPC-1.10.0
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/JSON-RPC/ChangeLog9
-rw-r--r--dev-perl/JSON-RPC/JSON-RPC-1.10.0.ebuild31
2 files changed, 38 insertions, 2 deletions
diff --git a/dev-perl/JSON-RPC/ChangeLog b/dev-perl/JSON-RPC/ChangeLog
index 475bcafc9f81..1b5d3e2fb659 100644
--- a/dev-perl/JSON-RPC/ChangeLog
+++ b/dev-perl/JSON-RPC/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/JSON-RPC
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/JSON-RPC/ChangeLog,v 1.11 2011/09/04 11:22:22 tove Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/JSON-RPC/ChangeLog,v 1.12 2012/02/14 15:05:54 tove Exp $
+
+*JSON-RPC-1.10.0 (14 Feb 2012)
+
+ 14 Feb 2012; Torsten Veller <tove@gentoo.org> +JSON-RPC-1.10.0.ebuild:
+ Version bump
04 Sep 2011; Torsten Veller <tove@gentoo.org> -JSON-RPC-0.96.ebuild:
Cleanup
diff --git a/dev-perl/JSON-RPC/JSON-RPC-1.10.0.ebuild b/dev-perl/JSON-RPC/JSON-RPC-1.10.0.ebuild
new file mode 100644
index 000000000000..1effd474e14b
--- /dev/null
+++ b/dev-perl/JSON-RPC/JSON-RPC-1.10.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/JSON-RPC/JSON-RPC-1.10.0.ebuild,v 1.1 2012/02/14 15:05:54 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=DMAKI
+MODULE_VERSION=1.01
+inherit perl-module
+
+DESCRIPTION="Perl implementation of JSON-RPC 1.1 protocol"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Class-Accessor-Lite
+ dev-perl/libwww-perl
+ >=dev-perl/JSON-2.21
+ dev-perl/Plack
+ dev-perl/Router-Simple
+ dev-perl/Try-Tiny
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-Pod
+ )
+"
+
+SRC_TEST="do"